GP SoftwareTwitter
Opus FAQsManualCommandsObjects

FTP files uploaded incomplete (not due to Opus)


#1

Hello there.
I’m using Directory Opus 12.7 Build 6540 to upload files to a FTP server (Cerberus FTP, latest version downloaded today).

When I upload, for example, a 18.9KB file (it’s a text file, html), the file just uploaded in the server is 16.00KB. When I login to the server via remote desktop and open the file with a text editor, I see that it has been truncated somewhere in the middle.

Then I try to upload it again and this time the uploaded file is only 14.3KB.
Then again and again and again, until 8 or 9 tries later, the file is uploaded correctly.

If I upload it again, then maybe it will be only 14.8KB again.

How can I debug this error? I’ve been using both Directory Opus and Cerberus for a very long time without problems. This problem only appeared a couple of months ago.

Thanks!


#2

What does the FTP log say when the file is uploaded?

Have you tried with the same file and server and a different FTP client?

Try turning off text/ascii mode in case it is involved.


#3

Hello there, I tried with a just downloaded copy of another ftp client and it does exactly the same.
So the problem is not Directory Opus. But it isn’t the ftp server either, since I have it installed in other 3 servers (same version) and it works great.

I changed the ascii mode with no luck.

Maybe the server is faulty, I’m going to further investigate, thank you.


#4

Sorry, the log says:

200 Type Binary
227 Entering Passive Mode (23,253,99,120,44,212)
150 Opening data connection
59566 bytes sent in 0.328 seconds (176.776 Kbytes/sec)
226 Transfer complete
213 Modify=20161102004531; Citla-gafete-v1.pptx
200 Type ASCII
227 Entering Passive Mode (23,253,99,120,44,213)
150 Opening data connection
2354 bytes received in 0.171 seconds (12.712 Kbytes/sec)
226 Transfer complete

The file has 59566 bytes on my computer, but the uploaded file gets less.


#5

Maybe something on the server is configured differently to the others. Or something running on the server is modifying the files after they’re written. Or while they’re being received (antivirus/firewall software sometimes proxies FTP connections and could be changing things at either end, perhaps).

I’d focus on the server side machine if you’re able to send to other machines OK from the same client machine, and since the issue doesn’t seem related to which client software you use.


#6

I’ll do that, thanks for your help.

P.D. I love Directory Opus, it’s a great piece of software.