GP SoftwareTwitter
Opus FAQsManualCommandsObjects

FTP no longer shows directory list


#1

I have an FTP site that's been working fine until a couple of weeks ago. Then it just stopped showing the file listing when I logged into it.

The data's still there, and I can see if I log into the ftp site from the command line, or IE7, but DOpus won't show it.

Here are the contents of the FTP Log:
230 User logged in.
--> SYST
215 XXXXXXXXXX
--> FEAT
500 Syntax error, command unrecognized: 'FEAT'
--> REST 100
350 Restarting at 100.
--> REST 0
350 Restarting at 0.
--> TYPE I
200 Type set to I.
--> PWD
257 "/" is current directory.
--> CWD /Public
250 CWD command successful.
--> PWD
257 "/Public" is current directory.
--> PASV
227 Passive mode entered (199,107,68,215,97,84)
--> LIST -alF
125 Data connection already open; Transfer starting.
3518 bytes received in 0.27 seconds (126.976 Kbytes/sec)
226 Transfer complete.

Everything looks fine but my lister is empty.

Any ideas?


#2

Since the directory listing appears to be received but nothing shows up, my guess is that the server is sending the listing in a format which Opus doesn't recognise. Maybe the server was updated to a new version which changed the format?

If you want to test this theory, connect to the server using FTP at the commandline as follows:

[ul][li]Open a Command Prompt[/li]
[li]Type ftp [/li]
[li]Enter your user name and then your password.[/li]
[li]Once you are logged in, type dir -alF and paste the results back here.[/li][/ul]

For comparison, I just tried this on a server which does work okay in Opus and got a directory listing which looks like this:

drwxrwxrwx 3 33 0 4096 Nov 13 05:54 ./ drwxrwxrwx 3 33 0 4096 Nov 13 05:54 ../ -rw------- 1 33 www-data 9 Nov 13 05:54 .ftpquota -rw-r--r-- 1 33 www-data 137867 Nov 13 05:46 SaveAs.png -rw-r--r-- 1 33 www-data 52607 Nov 13 05:48 SaveAsSmall.png -rw-r--r-- 1 33 www-data 49612 Nov 13 04:40 Sound.png -rw-r--r-- 1 33 www-data 161371 Nov 13 05:54 WindowColorandAppearance.png -rw-rw-rw- 1 33 0 2189066 May 17 2005 gta3p_island1.zip -rw-rw-rw- 1 33 0 2779301 May 17 2005 gta3p_island2.zip -rw-rw-rw- 1 33 0 2045496 May 17 2005 gta3p_island3.zip drwxr-xr-x 2 33 www-data 4096 Oct 28 11:33 news/

If it is the directory listing format then it may be possible to configure Opus to work around the problem. It could be something else so I'll wait to hear back from you first.

Also, just after you connect it should report which FTP server software is running at the top of the log. Which is it?


#3

Just noticed something else which is odd in your log:

125 Data connection already open; Transfer starting.

That seems strange to me since the directory listing should be the first thing which opens the data connection. Could you try completely exiting Opus and then restarting it and connecting again? Do you still get that message in the log?

It may be worth a try to toggle the PASV option on the FTP site's bookmark entry in case that helps as that has an effect on how the data connection is made, but if it doesn't help then please set it back to what it was.


#4

My format is very different than yours

dir -alF give me the following:

11-26-07  01:13PM       <DIR>          Heather/
06-26-07  06:50AM       <DIR>          Jackie/
10-16-07  05:13PM       <DIR>          Japan/
07-02-07  03:00PM       <DIR>          Justin/
10-21-07  11:15PM       <DIR>          Kemper/

Server is running
220-Microsoft FTP Service

I had tried PASV before posting - no effect.

Exiting and restarting DOpus has no effect as well. Same stuff in the log.


#5

Seems strange that the format should change 'overnight' so to speak?

Most MS FTP servers return a DOS formatted directory. It's possible you need to change the default Opus dir command. This should be changed to a simple "LIST" in the FTP Site Preferences.

If you still have a problem, send GPSoftware a formal support request with more details of the site etc and I can look into it for you.


#6

I tried to change the command to LIST in the site preferences, and I saw the call and data return in the output window, but nothing in the lister.

The FTP site maintenance said he didn't change anything, but I'm still digging into that.

I'll send a more formal report to the support email and reference this thread.


#7

This issue was caused by a non-standard setting on the FTP Site made by the site administrator.

Greg was able to work around the issue within DOpus and the change will be in, I believe, the next update.

Thanks, Greg. Absolutely fantastic support!!!


#8

Greg's middle name is FTP...