FTP timestamps - why no MTDM happening?

Ever since I got DOPUS at the start of the year, I've been puzzled by the fact that every file I FTP ends up with "time of transfer" instead of original file date. Finally, I've had time to have a closer look.

This problem persists with the latest version 10.1.0.0.4569.x64. When I look at the FTP log (with debug enabled), there is simply no MTDM command being sent to the Filezilla server at the other end:
--> PASV
227 Entering Passive Mode (x,x,x,x,x,x)
Waiting for Passive Data port connect
Starting SSL DATA connect
[DATA: TLSv1/SSLv3, cipher AES256-SHA, 256 bits]
SSL DATA connected
--> STOR favicon.ico
150 Connection accepted
226 Transfer OK
766 bytes sent in 1.341 seconds (0.0 Kbytes/sec)
(that's it)

Yet if I transfer the same file to the same server with another FTP client, there it is:
MDTM 20120710035826 favicon.ico

I've checked all FTP settings, it's not a timezone issue of course, and MTDM is set to "automatic" (and changing it to "UTC" does not improve things). Likewise "Preserve the timestamps of copied files" is enabled in general preferences, though I suspect it's not relevant.

So: why won't DOPUS issue an MTDM?

Is the FEAT command being sent after the connection is established? What does the server return?

Many thanks Leo. Global|Misc|FEAT had not been enabled, as I wasn't aware it had to be. It is enabled now and the problem is gone.

Glad it's working now.

Was FEAT turned off completely, or in the intermediate state? (It's a three-way checkbox.) It should be in the intermediate state by default, where Opus should automatically work out if the FEAT command needs to be used or not. It may need forcing into the "on" state for some servers. Setting it to the "off" state would be unusual.

Hope this isn't considered hijacking the thread, but I'm having the exact same issue (not SSL, though).
Files transfered via FTP does not maintain their local modified time.
It seems no MDTM is issued.
In the Site Properties I have MDTM = Use local and FEAT fully checked.
What can I do to further debug the issue?

Does the remote server support MDTM?

It does.
I can issue the command manually (tested in FileZilla), which works fine.
The remote server is an IIS.

Do you have the Preferences / File Operations / Copy Attributes / Preserve the timestamps of copied files option turned on?

Yes. It's on.

What does the FTP log show?

220 Microsoft FTP Service
331 Password required
230 User logged in.
215 Windows_NT
211-Extended features supported:
LANG EN*
UTF8
AUTH TLS;TLS-C;SSL;TLS-P;
PBSZ
PROT C;P;
CCC
HOST
SIZE
MDTM
REST STREAM
211 END
200 OPTS UTF8 command successful - UTF8 encoding now ON.
200 Type set to A.
257 "/" is current directory.
250 CWD command successful.
257 "/" is current directory.
227 Entering Passive Mode (x,x,x,x,x,x).
150 Opening ASCII mode data connection.
226 Transfer complete.
606 bytes received in 0.27 seconds (21.496 Kbytes/sec)
200 Type set to I.
227 Entering Passive Mode (x,x,x,x,x,x).
125 Data connection already open; Transfer starting.
226 Transfer complete.
1874 bytes sent in 0.27 seconds (67.392 Kbytes/sec)
200 Type set to A.
227 Entering Passive Mode (x,x,x,x,x,x).
125 Data connection already open; Transfer starting.
226 Transfer complete.
659 bytes received in 0.27 seconds (23.448 Kbytes/sec)

Please enable the debug log as the regular log doesn't show enough info.

I've been looking the option to enable the debug log, but cannot find it.
Where do I enable it?

Sorry. Found it.

220 Microsoft FTP Service
--> USER xxx
331 Password required
--> PASS ...
230 User logged in.
--> SYST
215 Windows_NT
--> FEAT
211-Extended features supported:
LANG EN*
UTF8
AUTH TLS;TLS-C;SSL;TLS-P;
PBSZ
PROT C;P;
CCC
HOST
SIZE
MDTM
REST STREAM
211 END
--> OPTS UTF8 ON
200 OPTS UTF8 command successful - UTF8 encoding now ON.
--> TYPE A
200 Type set to A.
--> PWD
257 "/" is current directory.
--> CWD /
250 CWD command successful.
--> PWD
257 "/" is current directory.
--> PASV
227 Entering Passive Mode (x,x,x,x,x,x).
--> LIST -alF
125 Data connection already open; Transfer starting.
659 bytes received in 0.27 seconds (23.448 Kbytes/sec)
226 Transfer complete.
--> TYPE I
200 Type set to I.
--> PASV
227 Entering Passive Mode (x,x,x,x,x,x).
--> STOR Create.cshtml
125 Data connection already open; Transfer starting.
5570 bytes sent in 0.27 seconds (201.176 Kbytes/sec)
226 Transfer complete.
--> TYPE A
200 Type set to A.
--> PASV
227 Entering Passive Mode (x,x,x,x,x,x).
--> LIST -alF
125 Data connection already open; Transfer starting.
713 bytes received in 0.27 seconds (25.400 Kbytes/sec)
226 Transfer complete.

This seems unusual. If FEAT and MDTM is enabled and supported by the server, the file dates should be being set after a transfer.

Can you contact me by direct email greg@gp.... and perhaps give us a login to the site and we can run some diagnostics.

Done.
I've sent you an email with the login info.
Thanks.