FTP to desktop results in partial file

I've noticed a bug regarding dragging and dropping files from an FTP folder in Dopus 10 directly to the desktop. For some strange reason the file isn't complete once it's downloaded.

For example I downloaded some PHP files from an FTP server and all of those that were dragged to my desktop were incomplete downloads.

If I use the twin pane in Dopus the same file(s) downloads correctly.


Are you dragging to the Windows desktop itself, or to another Opus window showing the Desktop folder?

To the actual Windows desktop. Is that bad?

It's not necessarily bad but it makes a difference since it means Windows Explorer is on the other end of the drag & drop, instead of it all being handled by Opus.

If you drag to an Opus window, does it work then?

Are there any error messages or anything else unusual in the Opus FTP log?

Also, which version of Opus are you using?

Transferring to another dopus window with the desktop open in it is fine.

Directory Opus 10 x64

The FTP log shows exactly the same thing for transferring to actual desktop or to opus windowed desktop.

For what it's worth, I had the same problem when 7 beta first came out and I was testing it. I didn't mention it then but I do believe I was drag-n-dropping to desktop.

I just learned to open a new tab with desktop and drag to that. Or right-click on ftp file -> download and pick the desktop. I never went any further into looking at logs or anything. Faster to just leave Explorer out of it, was my thought.

Does this happen with all files, all the time, or only sometimes with random files?

Only with large or small files, or can it happen with both?

Executable files seem to be ok, I downloaded an installer directly onto my desktop and that worked just fine. Seems to be just text based files.

I just tried a bunch of randomly sized files (10-90MB .exe's, 1-10KB gifs, etc etc) one at a time and it all worked for me now. Sorry, I can't say it's not working for me now.

ARSoftware, Just out of curiosity, Do you have UAC turned on or off?

UAC is off. I'm going to be using a different PC today so I will see if it exhibits the same problem.

One thing that may or may not affect it; I have Stardocks Fences installed which is used to section of desktop icons in to groups. I'm wondering if that is interfering somehow.

Ok, I've just tried transferring a PHP file from a different PC to my desktop (directly) and that was also missing part of the file.

As I mentioned before it seems to be OK with executables, image files, binary files, etc. It only seems to affect text based files.

I've been able to reproduce this - it only happens when transferring a text file (with ASCII or Automatic modes enabled) and is caused by the actual file (with CR/LF conversion) being longer than Explorer is expecting. We'll see if we can find a solution for this in the next version.