Global Filter Wildcard -- hide "Notizbuch öffnen.onetoc2"

Due to the mess that one other collegue did, all of our working folder contians one file named "Notizbuch öffnen.onetoc2", and i was thinking that the "Global Filter" would just do the trick to hide them for good.

However, I tried with below settings, it doesn't work.
Notizbuch öffnen.onetoc2

Did I do anything wrong, please?

thank you.

You have Use regular expression turned on, but the string is wildcard. Just turn that off and it should work as-is.

Hi, Leo
Actually i have thought of that, when i uncheck that, all files disappeared...

Try keeping RegEx, but add a . before the *.

It's because of the ~ character.

I think the aim is to ignore files that start with ~$, so switching to regex won't work on its own either.

If you keep wildcard mode on:

  • ~ is a wildcard character. You should escape it as '~

If you switch to regex mode:

  • $ is a regex character. You should escape it as \$

  • . is also a regex character. You should escape all of the dots as \.

  • * works differently in regex. You should change both of them to .* or .+

Hi, Leo,
Thanks for explanation.
with Wildcard mode, I fixed it with adding ' to escape ~.

However I tried as @lxp said "Keeping RegEx mode and add . before the * "


it doesn't work still.

So first of all, issue solved, thank you both!
secondely, if you feel like further explaining to me RegEx mode failure, I am super glad go learn.

From the screenshot, that looks like a ` (backtick) before the ~ character. It should be a ' (single-quote).

Hi, Leo,
thanks for the remind.
But as I doublechecked, it's just a different displaying way of the normal single quote symbol ' (don't understand this German-setting environment), so it's correct.

What do you get if you copy & paste what's in the filter into the forum?

It looks like the wrong character. No font should turn ' into `.

(I've noticed a few posts by German users where ` is used instead of ' in forum posts, which might mean getting a ' is harder on that keymap, although I haven't looked into it in detail.)

No, it's not harder. Just stupidity. :stuck_out_tongue_winking_eye:

Below picture is what it looks like as a screen snap:

Below is the text per se:


BTW i am using an International keyboard (QWERTY) instead of local German QWERTZ one (I am not local German), so shouldn't be issue of physical key mapping issue.
the OS is with orginally German Win10 but I swtiched into English -- in case it matters.

That's a left quotation mark. What you want here is an apostrophe '.

Seems to work nonetheless. But looks odd :wink:

It actually is easier, but programs like Word are superb at automatically converting apostrophes into left and right quotation marks.

1 Like

aha, Indeed!

But yes, both "left quotation mark" and "apostrophe" works here.

thanks for making it clear.

But then I am confused how do I directly send a simple ' from my keyboard :thinking: :thinking: :thinking:

Strange. Only ' works here, and it's the only character the code looks for. and ` don't work for me.

Strange. I wouldn't know how to generate a quotation mark :smiley:

Same here.

@Bryan.H I guess your company's keylogger needs an update :wink: