GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Global hide filter not working in flat view (mixed, no folders)

Hi guys, I have the global hide filter set to hide any ".git" folders, this works fine in flat view (grouped or mixed) but the folder and files show up with flat view (mixed, no folders). I have attached a screenshot.

There's a setting you can change:

That option is enabled, but I am using the "no folders" flat view, so no folders show up and there is no checkbox, the problem is the files in the filtered folders are showing up.

The folder filter is ignored if no folders are shown, but it'll work if you use either of the other two modes (Grouped or Mixed).

Alternatively, using Tools > Find Files (Advanced) might be preferable, if you want a flat list of file-only results. With that you can filter by path easily.

So the folders and files within are filtered out when you choose to show folders [mixed], but the files are visible when you choose not to show folders [mixed, no folders]? Seems counter-intuitive to me, I think that [mixed, no folders] should work just like [mixed], except without listing the folders at the top.

Don't you think this is a bug? Isn't the purpose of the global hide filter to remove folders (and thus the files within) from all views? Why would you have a view mode override a global preference?

I can see where you're coming from but it's not a bug. The Flat View (No Folders) mode already filters out all folders, so any additional folder filters aren't relevant to it (the folders are all already filtered out) and the option to hide things below filtered-out folders cannot be applied to it (because it'd remove literally everything).

Okay, not a bug.

How come the files don't show up in Flat View (Mixed), but do show up in Flat View (Mixed, No Folders)? Surely it can't be a technical limitation considering the amazing things you have done with Opus.

By the way, I know I'm being pushy and probably irritating, so let me know if you'd rather not continue the conversation and I'll just accept it and move on. :innocent:

Thanks for reading.

I :heart: Opus

Flat View filtering has two modes. One where filtering out a folder also removes all the files under it, and one where filters aren't applied to folders at all.

You can use either mode with Mixed and Grouped.

But you can't with No Folders because it wouldn't make sense; it would hide every single file and folder.

Does it have to work that way? No. Could we change it in the future? Possibly. But that is how it works right now and was designed to work.

Possibly :crossed_fingers:

(Please consider applying the global hide filter from preferences in all cases first)

I'm done, thanks for the chat.

Cheers Leo!

It's not that the global folder filter isn't being applied. Do you see any folders in No Folders mode which aren't filtered out? No, all folders are filtered out in No Folders mode.

What isn't applied in No Folders mode is the separate option which hides files that are below filtered-out folders.

But if that option was applied, you would not see anything in No Folders mode, because all folders are filtered out in that mode, and thus all files would be as well.