Global Hotkey Parameters problem

C:\Program Files\GPSoftware\Directory Opus\doptest.exe "%1"

Hotkey: Win +/

When it is NOT global

doptest returns the currently selected file

When it is GLOBAL (system-wide hotkey checked)

doptest returns "" (i.e. no parameters)

(with or without a lister active!)

I have tried with several variations ({file} {file$} ...etc)) but it seems like it doesn't help.

this is only a HOTKEY not a button. So is this a bug or intentional?
Any workarounds?

using version 9.1

you know it was working before... i had metapad set like that... but then now it has stopped working. Don't know what happened. Ideas?

P.S. I did search the forums for 2 hours but no luck.

Global hotkeys can't insert selected filenames. They have to be able to run when triggered from any application, and if you trigger them when a random other program is active then there's obviously no file selection to pass to them.

Edit: Although, hmm, if it used to work then maybe previously it was run like a local hotkey if Opus was active, and a global one otherwise... Perhaps something changed there.

Strange but it's working on the PC today.

As in the file is being passed to notepad2 correctly and it's opening it. however, doptest still doesn't get the parameters.

I'm left scratching my head over this. Does it have to do with Keyboard hooks and all that?

Or with ClipX, a clipboard enhancer?

Even with a lister open and not active it works!


I just figured it out.

If i have multiple listers open it stops working!
if i have only one open it works.

I guess with multiple listers it doesn't know which lister to pick and which selection. (it doesn't work even if i have one of the listers active!)... (i only use dual listers, haven't tested with 2 single lister)

so i think this might be a bug. Can someone confirm this? Thanks.

If you only have one window open, does it work if it's a single display and not work if it's a dual display?

In other words, does it need at least one single-display window open to work?

That would make some sense since dual-display windows are "self contained".

Sorry to intrude this discussion, but I have a similar question.

I tried to set a hotkey in Dopus to show the find window when I press the "Search" key on my Microsoft Comfort Keyboard, but it look like Dopus does not recognize these special keys.

If I now click this button, the MS Search assistant appears while I rather use the DO Find function.

Thanks for the help.

Your keyboard drivers probably let you configure a command to run when that key is pressed - if so, set the command to "C:\Program Files\GPSoftware\Directory Opus\dopusrt.exe /cmd Find"

Hi jon, the problem is, I don't have any special drivers installed for this keyboard, they use the default MS keyboard drivers.

It's weird because I could assign such a hotkey in foobar2000, where I set the "Play" button on the keyboard as a global play/pause hotkey for foobar2000. Just for your info, when I assigned it in foobar, "Play / Pause (MM)" appeared in the field in foobar. So I guess it's probably a matter of implementing the detection of these keys.

If you're using XP then I think you can use Microsoft's TweakUI tool to change the default meaning of the special keys.

I just tried it with TweakUI nudel, there's just one problem, it doesn't support command line switches.

Ie. I can make the button run "C:\Program Files\GPSoftware\Directory Opus\dopusrt.exe" ... unfortunatelly if I make the command :

"C:\Program Files\GPSoftware\Directory Opus\dopusrt.exe /cmd Find", tweakUI says it cannot find the program. :frowning:

Please disrgard above, it works now !! :slight_smile:

Command = "C:\Program Files\GPSoftware\Directory Opus\dopusrt.exe" /cmd Find

see the above url for an alternative solution to your Keyboard Control problem. I haven't tried it, but autohotkey works great for small annoyances!

BTW this series of posts should be split to a new topic!