Help, I think I've broken something

Running DOpus latest version, on Windows 10 I discovered, about 10 days ago, that I could no longer open folders on the Desktop with a double click. A double click simply resulted in nothing happening. If I right clicked and chose Open In Directory Opus it worked, but that isn't always what I want to do. So I looked for an answer and came up with something that appeared to work, in that double clicking a folder opened Directory Opus at Desktop Level. However, I've now discovered that double clicking a folder at any level of the structure open Directory Opus at the Desktop Level. Is there an easyish answer to this, or should I uninstall DOpus and reinstall it, in which case will I lose my licence? Yes, I know I'm unbelievably thick, but that's what you get with an English Springer Spaniel.

What was the change your made? If we know that we can give better advice.

Oh don't I wish it was that easy. I've forgotten, silly little Spaniel. Well, I could say something else but it would get me thrown out of the forum.

Might it be this: Go into Prefs, Choose File Types, All Folders. Select Edit then it reads Action: Open Type: Run an Application and Application reads: "C:\Program Files\GPSoftware\Directory Opus\x86\dopus.exe"

If I've been looking for a solution to an unresponsive double click, I probably went looking in the Preferences: Is the above how it should read in an unmolested DOpus, or have I inadvertently changed something so that the result is that when I double click on any folder it Runs DOpus from scratch.

If that isn't it, you might be forced to tell me that I'm a poor deluded twerp, but, Hey, I already know that!

You definitely do not want to have that setting, but repairing it may require some registry editing.

Please run FileTypeDiag and click Save with a blank extension, to save information on the folder filetype, then attach the result to a post here.

I knew it, if there is stupid to be done you can count on me. My grandfather used to tell me off for taking toys apart to see how they worked. I could never see how they worked and never put them back together either. Sorry for taking up your time.
Folders.txt (332 KB)

[ul][li]Open RegEdit.exe[/li]
[li]Go to HKEY_LOCAL_MACHINE \ SOFTWARE \ Classes \ Directory \ shell[/li]
[li]Right-click open[/li]
[li]Choose Delete[/li][/ul]


Okay, I have done that. Sorry for the delay but sometimes life gets in the way. I have not yet tried to see what effect that change has had, and I may need to reboot, but as your post does not say so, I guess that I don't.

I shall let you know!

Hello Leo. I think that we may have reached a point at which you cannot help me, because I think that this goes beyond DOpus and into the realms of Windows 10.

Thanks to your advice, which I followed to the letter and which worked, I am now back at the position I was in before I started changing variables. Now when I double click on a folder icon on the desktop I get a message about not being able to carry out this command and that I need to set a default program (see the attached screenshot). I have looked in the Default Programs bit of the Control Panel and it does not give DOpus as even an available option. I tried using it to set the Default to Explorer (or whatever it is now called) but that has had no effect at all.

If I right click a folder it will allow me to use open with DOpus, and that works as it should in that it will now open the folder I've pointed at, but I just want to go back to the good old days when clicking on a folder opened the folder.

I have upgraded DOpus to 16.1 Beta in order to get the Open With Default, but if I am right clicking on a Folder then I don't get OpenWith in the Right Click Menu.

If you have had enough of me by now, please just tell me so and I will have words with Microsoft. I am eternally grateful to you for the help you have given to this post pension partisan already.

Many Thanks. Kevin


Try setting Preferences / Launching Opus / Explorer Replacement / Don't replace Explorer, then click OK.

What happens when you double-click a folder then?

Good Afternoon

Now I'm beginning to get concerned. I followed your advice, changed that preference in DOpus. Rebooted just in case it needed a reboot to work. Tried double clicking on a folder and I get exactly the same message as before.

This begins to look like something a bit more serious, and I'm beginning to think that I need to look into the possibility of doing a clean Install of Windows 10 and reloading my software. This is a major job, but I have clearly broken something, some link or connection, or I have installed a piece of software that has caused this issue. At least if I have to reinstall everything I can test it all, piece by piece, though that is a hell of a job.

The other thing that I have notices is that if I do a right click on the desktop I get a much shorter list of links than I used to get, and I can no longer create a new folder by right clicking the desktop, I have to go into DOpus and create a folder from there. That works.

Any ideas would be most welcome, though I think that this has now no longer got any connection to DOpus.

Thanks for your help.

Kevin

That does sound like something or maybe more than one thing is broken in Windows, outside of Opus. I'm not sure what to suggest other than repairing or reinstalling Windows.

The repair option may be worth a try and if it works will save you a reinstall: support.microsoft.com/en-gb/kb/929833

Thanks Leo, I shall try the Repair Option and see where it gets me. It is, as you say, a better option than a full reinstall. At least there is not a catastrophic crash so I can take my time, make sure that everything is properly backed up and up to date, then have a go at it over the weekend. We'll consider this closed, though I may, afterwards, let you know what happened in the end. Other than that. Thank you and out!