Help - Messed Up "Open With"

I have a number of Acronis archive/backup files with the extension .TIB
Up until now, using Opus 12, I have always double clicked on the TIB file and it has opened in Windows Explorer, where it asks for the password and then opens.

I was recently moving some files and tried to stop the move half way through and somehow messed up things. Now when I double click on the TIB file I get the message
"Directory Opus:
"An error occurred reading folder. The directory name is invalid. (267)"

However, when, instead of double clicking, I right click on the TIB file, and select "Open With" and select "Windows Explorer" in the box that opens (which is ticked as the default "Always use the program to open"), the TIB file opens as normal in Windows Explorer, where it asks for the password and then opens.
Similarly, if I open the TIB file from within Windows Explorer, it opens as normal.
If I look up "File Types" in Opus, the TIB files are set to open with "Idlist,%I,%L ". I don't know what this is.
I tried to change that to "Windows Explorer", but that made it even worse - nothing opened but the cursor just flashed and dozens of instances of Windows Explorer had opened when I looked in Task Manager.
I have obviously broken the Open mechanism somehow, but have no idea what's wrong or how to fix it. Can anyone help, please?
NB My "Explorer replacement" setting in Opus is "Replace Explorer for all file system folders"

Thanks in advance
Guern

Moving files wouldn't normally change how programs or file types work, unless the files you were moving were part of one of the programs involved. Is there a missing detail here that might help work out what happened?

Have you tried reinstalling Acronis? That would usually fix any issues with its components and registry entries.

Thank you Leo,
Re missing detail, possibly I missed something - I was trying to stop the file beeing copied across and it wouldn't stop, so I tried different things to force it to stop, and eventually shut down and restatrted the PC and got Windows to stop the copying.
Reinstalling is a possibility, but I'm reluctant because I will lose all my settings and have to recreate them all. Any other possible ideas that I could try first?
Best
Guern

PS: Do you know what "Idlist,%I,%L " is?

OK that changes things somewhat. Especially depending on what all the "different things" were.

Reinstalling software over the top of itself usually doesn't wipe your settings. You don't need to uninstall it first to repair things.

It's one of Microsoft's many cryptic ways to run a command.

Thanks Leo
I tried uninstalling and reinstalling Acronis (no repair option), but the problem has not gone away, I still get this message when double clicking on a TIB file:
"Directory Opus: "An error occurred reading folder. The directory name is invalid. (267)"

Could you expand on what that means please?

Cheers
Guern

It usually means something is trying to access a folder which doesn't exist.

If you right-click a TIB file, are there other options for how to open it there? Do any of them work?

Another thing to test is turning off Explorer Replacement in Opus (Preferences / Launching Opus / Explorer Replacement), although if it is on the recommended "filesystem folders only" mode then it shouldn't get involved with True Image's virtual TIB drives unless they're mounted as real drives/folders.

Thanks Leo
If I right click on the TIB file, and select "Open With" and select "Windows Explorer" in the box that opens (which is ticked as the default "Always use the program to open"), then the TIB file opens as normal.
The other option, which does not help is "Directory Opus helper Application".
I have therefore turned off Explorer Replacement in Opus (i.e. set to Don't Replace Explorer) and then the TIB file opens as normal.
I have not yet worked out what the downside will be to turning off Explorer Replacement. Have to use it and see what happens.
Cheers
Guern

What happens if you set Explorer Replacement to the recommended setting (all filesystem folders) instead?

TIB images aren't filesystem folders so it shouldn't affect them.

Thanks Leo, but setting Explorer Replacement to "all file system folders (recommended)" doesn't work. That was what it was set to before I turned it off.
The other two options don't help either. Only "Don't Replace Explorer" works. (So far it has not given me any negative effects.)
I think something weird has changed in the registry and we'll never know what it is.
Kind regards
Guern

You can use Settings > File Types, and then File > Diagnostic to create a dump of the registry for a given file extension.

Would probably need to compare it to a system with TI installed and working normally to see what was wrong.

Many thanks Leo, but I'm afraid you've lost me.
I got as far as Settings, File types, and then chose TIB.
But I don't know where to find file diagnostic or to do a registry dump.
Kind regards
Guern

From the File menu:

image

image

Thank you Jon
I never even knew there was a menu there under "File"!
I have saved the config and will compare to my other PC.
Cheers
Guern