High contrast black mode not respected

Colors are broken if I enable high contrast black color scheme in Windows 8. Please respect system settings.
Thanks and regards,

Which colours are wrong?

In the very first place, the big two panels displaying the files/folders have white background, while e.g. Explorer correctly has black background. Then the items in "Options" are hardly readable. I did not investigate more.

I see what you mean.

The file display colours can be changed under Preferences / Display / Colors and Fonts (it's the first page in English, but may be sorted elsewhere in the list in other languages).

Although many of the colours default to coming from the system, the file display ones don't because there aren't system-defined colours for a lot of those things, and drawing non-system colors on top of system colors can result in things which are hard to read (which is exactly why the categories in the Preferences dialog are hard to read in this situation; something that's on our list to fix).

I've made a note to see if we can improve things here, maybe by having a second set of default colours for when everything is inverted.

Thanks for your response. I am not sure if I follow your reasoning though. I just want to switch high contrast in system settings and DOpus behave accordingly and usably, without tweaking any configs.

Thanks a lot