GP SoftwareTwitter
Opus FAQsManualCommandsObjects

How do I disable beta notifications?

Somehow the "Check for new Beta releases" button got enabled. I've turned it off, but DOpus is still informing me that 12.14.1 Beta is available. How do I disable this? I tried reinstalling but that didn't fix it.

Preferences / Internet / Updates / Check for new Beta releases

Hi Jon. Could you provide more info? As I already stated in my post, I have disabled that setting.

What version are you currently running?

If the update checker has already detected a beta, and then beta detection is turned off, the notification in the status bar and (if turned on) system notifications will still show at the moment, due to the detected update being cached.

As a workaround, after turning off checking for beta updates:

Go to /dopusglobaldata\Global Data and edit globaldata.omd in a text editor.

Remove all of the attributes that start with update_, i.e.

update_download_low="65536"
update_download_high="786446"
update_size="57743976"
update_lang="english"
update_new_low="65536"
update_new_high="786446"

(The values in quotes may not be the same. The names are the important part.)

Then fully exiting Opus (via File / Exit Directory Opus) and restart it.

Edit: The workaround shouldn't be needed anymore from 12.15 onward.

Thanks, Leo. That fixed it.