How do I enable Unicode with SFTP?

How do I enable Unicode with SFTP connections? I have some folders and file names that are written in Russian that are on a Linux box and served to Windows via Samba. When I look at the files names from the Linux shell or via the Windows share using DOpus, I see the Cyrillic characters and everything is correct. However, if I make a SFTP connection to the server and view the file names, they are displayed as strange garbage characters.

I can't enable UTF8 in the profile for the bookmarked SFTP site as that tab is grayed out. I did enable UTF8 in the default profile, but that made no difference.

Unfortunately, Opus doesn't currently support UTF8 for SFTP. We'll look at adding it for a future update.

Is there any progress on this issue? UTF-8 support for SSH based connections is essential, because nearly every linux distribution uses this encoding as default.