How do I stop viewer as default action for xcf format?

how do I stop viewer as default action for xcf format (gimp pictures)?

XCF is not a file type that Opus views natively.

If you've installed a viewer plugin for it, disabling that may be what is required. Otherwise, if the Opus viewer is involved at all then it's likely because something has been configured explicitly (e.g. adding XCF to the Images file type group, or changing the double-click action on the XCF file type, or using the Open With menu). The details of how to undo that will depend on what was done.

Are we talking about the standalone Opus viewer window, or the preview pane? From inside Opus or outside Opus as well?

(Are we definitely talking about the Opus viewer and not a different one?)

standalone Opus viewer window -> yes it is definitely the Opus viewer
only from inside Opus does it open in the viewer

But I now realized: It happens because of this plugin: Universal Graphics Viewer Plugin (Universal Graphics Viewer Plugin). If I deactivate it, all is back to normal. Is there a way of how to use the best of both worlds? Or even is there a better xcf/gimp-thumbnail creator (this plugin uses only the top graphics layer from inside the xcf format - horrible)?

You could override things in Settings > File Types if you want to keep that plugin for other formats but make .XCF files do something else when double-clicked.

Some plugins also let you control which types/extensions they handle by default but I don't know if that one does. (It is not one of the ones that I/we wrote ourselves, so we know less about it and can't modify it ourselves.)

ok, I tried seeing "open" as default action for that file type but did not think of double click. thx will try

ok, I did not try to play around with that plugin any further.

Instead I am using sagethumbs now (
I read somewhere that that plugin and sagethumbs are based on the same library (Pierre-e Gougelet's GFL library (XnView's author)).
Well, sagethumbs works ok for me (Win 7) and I found a fix for the bug described before:
In a gimp file I must place all layers in a layer-group. Then the thumbnail creation seems to work ok even in the cases where it did not work before. Being happy now. Thx for the support, leo, even though it was mostly "emotional support".