How to auto complete in mapped drives

Running 10.5.50

Just getting up to speed on a brand new re-install from scratch.

Before doomsday crash, opus would auto complete in mapped (remote) drives same as local.
Now after a fresh install if I set a mapped drive in the location bar and start typing a directory name it makes me complete the whole thing.

After fiddling in settings a while I'm not spotting the one that controls that.

Preferences / Folders / Folder Behaviour / Complete paths for local drives only.

(Or just type "complete" in the search field at the bottom of the Preferences dialog)

Thank you jon. For the many answers