How to disable the automatic preview?

I find it very annoying when the internal (or the external player I've enable through ActiveX) starts playing the media files automatically...

Automatic preview of what, when you do what?

When I click a video file in the lister --> The video starts playing in the preview panel.

So the preview panel is previewing the file you click on - as it's supposed to.

Turn off the preview panel when you're not wanting it or configure the plugin:

Prefs // Plugins // Viewer // Movie // Automatically Play Movies

Thx, that was the exactly I was looking at.

Strange, I completely turned off the "movie" plugin. "Automatically play movies" was turned off anyway. But they still keep playing away?! This is so confusing me.

If you turn off the Movie plugin, the ActiveX plugin will handle movies instead.

Do one of the following:

  • Turn the Movie plugin back on, and turn off the Automatically play movies option in its configuration (as suggested above).

OR

  • Configure the ActiveX plugin and turn on the Windows Media Player Preview Handler (which waits for you to click it before it will play anything; ignore the warning about it being a worse player, it's the lack of auto-play which makes it 'worse').

OR

  • Configure the ActiveX plugin and remove the video extensions from its Generic ActiveX 32-bit line (if your aim is not to disable auto-play but to disable video viewing entirely).

Thanks "movie" is turned back on and now works showing video controls but not playing. I switched "movie" on/off heaps before with "Automatic Play" unchecked but they always played.

Actually... while some video clip file types are not automatically playing, I just tested a ".mp4" video clip, and it plays despite Movie Plugin settings being set with Automatic Play off and ',.mp4' added as a Recognized filename extension. Perhaps I was testing on mp4 video clips earlier and that is why I was getting no where, and for some reason Automatic Play always ignores it, even with mp4 as a recognized extension . I am curious is that expected behavior or should adding extension .mp4 also apply to Movie Plugin settings?

Turning off Active X works for mp4 so at least that has stopped it. Thanks heaps.

If you don't have the right (64-bit) codecs installed for the Movie plugin to play a file, it will drop through to the ActiveX plugin which may then be able to play it using something else (including via 32-bit codecs).

It tells you at the top of the preview pane which plugin is being used to display the file, next to the filename. (You may need to make the pane wider if the information is being truncated.)

See Enable/fix playback of various media formats in Opus for info on codecs if you want to get everything working in the Movie plugin. Or turn on the [b]Windows Media Player Preview Handler[/url] in the ActiveX plugin to top it from autoplaying most movie files which drop down to it.

(Or close the preview pane if you don't want it playing movies while you're clicking on movies. That's what I do, and it's made easy to toggle on & off with one click for this kind of reason.)