How to temporary disable lister filters?

How can I temporary disable lister filter? I hide files matching *~ but I sometimes want to see them (just to delete them). How can I unveil all files w/o removing the filter? I though shift/ctrl etc click on status' bar field reading (x hidden items) would work, but seems it does not

Try Clear Local Name Filters in the menu:


This is partial solution I am afraid, because I can easily get filters back without closing/reopening listers or doing anything similar. That's why I hoped for i.e. ctrl click on status bar

Not sure what you mean. It's a problem because you can easily get the filters back?

Ignoring how you activate the action (via status bar or menu), what do you want to happen instead of what happens now?

i want to disable filters (not remove), do what I want and then get it back on with ease. The last step is what I miss currently

Just click on the current folder in the path field to re-load it, with the filters turned back on.

Not sure if this will help you. I use Global Hide Filters to always hide .ini, .db etc. under Preferences -> Folders -> Folder Display -> Global hide filters. I have "Enable global wildcard filters", "Hide hidden files" and "Hide protected operating system files" all checked.

I then use the below code to toggle these filters on/off.

Set GLOBALHIDEFILTER=Toggle Set GLOBALHIDEHIDDEN=Toggle INVERT Set HIDESYSTEMFILES=Toggle INVERT

[quote="Borszczuk"]
[/quote][quote="leo"]Just click on the current folder in the path field to re-load it, with the filters turned back on.[/quote]

If I do "Clear local name filters" as you suggested, reloading does not bring filters back here (which is because these are removed?)

Pushing Refresh/F5 won't, but doing what I said will. Or at least it does here.

You can click the various icons on the filter bar to disable/enable filters without clearing them.

what "clear local name filters" is:

Set SHOWFILTERFILENAME=""
Set HIDEFILTERFILENAME=""
Set SHOWFILTERFOLDERS=""
Set HIDEFILTERFOLDERS=""
Set HIDEFILTERATTR=""

so aren't filters simply gone - seems so, so it shouldn't be back on reload. anyway - this is not happening here though.

How are the filters being set in the first place?

I've been assuming they are part of the folder format, but maybe you're using a different kind of filter.