I accidentally F**ed my file types

a while ago i managed to break my file type then managed to "make it work" but never fully fixed it
sry LEO xD but you are around how do i set them back to default or just tell me how to set them up

ill also show you how it works right now
2023-01-30 09_37_04-

sry for bothering you again but i never got around to asking how to get that back yo normal it works but its the wierdst sh*** hahah

Att Didier and thanks

Best thing to do is copy the registry settings from another PC running the same version of Windows.

Is it just the folder actions which are wrong? Which version of Windows?

yes only folder actions, and I'm on windows 10 22H2.
is see about asking a friend that also uses opus to see what he has there. if there is no easy way ill just change one by one

Looking on my machine, it's normal for the "All Folders" type to have a mostly blank Actions tab. (It shows the Directory file class, while the actions File Explorer uses in the registry are in other places like the Folder class. The Directory and Folder classes are related but slightly different, and Folder is not exposed in Opus's file type editor (since it largely doesn't matter inside of Opus).

These reg files should get your Folder class back to normal for Windows 10 22H2:

Folder_Shell.zip (1.7 KB)

(For anyone else finding this post, the HKCU file in the zip should only be used if Opus's Explorer Replacement is on. Otherwise just use the HKLM file, which doesn't contain anything Opus-specific.)

(sorry for the delay i had a work call)

it seems i messed with the windows ones, not the opus ones... i dont even know how i did it. and i work in the industry.. my god.

a million thanks anyways. (if you know how to edit the windows ones >.> it would be highly appreciated if you tell me where to look or have some idea or regs xD that would be great, you have been incredibly help full thanks again)

thanks again for the help. love the software the problem was me this time xD

The reg files in my previous post should fix the main Windows entries.

oh i added/runed both and restarted and its still the same...

how did i ever change that. it must be the weirdest thing

sry for the miss message on the other post was looking for this one... this is what i sent

found it need this!
( context menu - Change "Run as Administrator" label - Super User )


that's where the problem is. sorry to bother but can you export yours being that we are both using the same windows in the same language.
i think this might be it

2023-01-30 15_41_03-

didn't eve had to restart omg thanks man you pointed me in the right direction !!!

THANKS for the awesome support you always give

Strange; the exefile class shouldn't have affected what your folder context menus looked like.