GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Icons for each folder/file now disappear


#1

With the last couple of upgrades, whenever I open Directory Opus all of the icons to the left that used to signify files or folders now show up for a second then all disappear. What is the problem here and how do I fix it to operate the way it used to (and was supposed to).


#2

That is most likely caused by a bad shell extension, returning empty icons for everything when Opus asks Windows which icons to display.

Cloud storage tools seem to be the most common cause of this bug.

ShellExView is a tool you can use to list shell extensions and try disabling them. Look for ones that where the type involves icons, try disabling them, and then fully exit Opus (via File / Exit Directory Opus) and re-launch it to see if the problem is still there.

In some cases, clearing the icon cache may also help, if the issue is the Windows icon caching is corrupt and returning blanks.


#3

I have the same problem, and have had the same problem for months. it only seems to affect my documents folder, and all subfolders but that is bad enough and a deal breaker - I'm going to have to give up dopus if this can't be fixed.

I do not udnerstand the instructions above - ie, how to handle shell extensions, and I cannot spend hours working this out. I tried clear icon cache but it did nothing (except make windows diesappear which was a bit scary.

Are there any clear instructions out there to fix this problem?

thanks

Don


#4

[ol][li] Run ShellExView.[/li]
[li] Click the Type column to sort by it.[/li]
[li] Find the first Icon Handler in the type column and click on it.[/li]
[li] Find the last Icon Overlay Handler in the type column, hold shift and click on it. (You should now have all the Icon Handlers and Icon Overlay Handlers selected.)[/li]
[li] Right-click one of the select items and choose Disable Selected Icons[/li]
[li] Reboot the PC.[/li][/ol]

After seeing if the problem remains, you can enable some of them again in a similar way. Do that to narrow down which one is causing the problem. It's usually ones that are part of Cloud Storage software, for some reason.


#5

I had this problem quite a while ago, but only some of my custom icons were affected. Then it suddenly worked again, before I was motivated enough to search for a solution.

Now the problem occurred again, additionally (and massively) affecting the directories and files of my Git repositories that are marked with overlays.

Leo's tip helped a lot (thank you very much!); using ShellExView I could identify the newly installed version 5 of ExpanDrive (upgrade from version 4) as the culprit. After deactivating the two icon overlay handlers, everything worked just fine again in DOpus.

The only thing I don't understand is that the Windows Explorer had no problem whatsoever to display the icons. Might there be a more robust way to display the icons? I can understand the developers of programs like that - I guess I wouldn't test it in every file manager if it works in the Explorer...

However, I'll contact the developer of ExpanDrive; maybe he can solve the problem.

Cheers,
Jan


#6

Hm, I just notice that the Windows explorer doesn't show the repository overlays at all. I guess that's why the problem didn't occur there... :unamused:

Cheers,
Jan


#7

Part of the problem is Windows only has 16 slots for overlay icons. Some shell extensions will reserve most of those on their own!

Within each process, whichever extension reserves the slots first wins, so you can end up with different overlays working and not working in different programs, and between reboots.


#8

That's an interesting information, thank you very much!

Cheers,
Jan