Ignore prefix when sorting not working as expected

There is a setting in the preferences:

Which should ignore the given prefix(es?) when sorting. However, when enabled this doesn't work for me as expected.

Turned off: 2017-08-21 22_12_58-Einstellungen

Turned on: 2

So in essence it doesn't do its job, it only moves all elements with the "The" to the top.

What I expected—and I presume what most would consider the correct way—is the order
The A
The Z

Please fix this. I'm on DO 12.6 Pro. Maybe another setting could be whether the "A" or the "The A" is placed as the first.

Are you putting a space after 'The' - like so 'The ' in the global filters preferences?

No, there is no space after "The". I tried it with "Test", same behaviour as with "The". I tried "A", now it works correctly.

If you don't include the space then only the "The" is being ignored, which means the names are sorted beginning at the space. Since spaces sort before letters, you get " A" and " Z" followed by "A" and "Z".

1 Like

Thanks. I assumed the setting would include the space automatically and just consider full words.