Image viewer - Open with

When seeing the image, I often want to do something with it, e.g., open in a photo editor. I'd like to be able to right-click and select **Open with...*. But that option is not there. Can it be enabled or added? Or is there a different way to get that functionality?

Even better would be a quick way to open it in a predefined editor that I use most often. Possible?

You can edit the menus and toolbars in the image viewer the same as in the main file displays. While editing toolbars (Settings > Customize Toolbars from the main window), you can simply drag the .exe file of the program you want a button for to a toolbar, including the viewer's toolbar.

More information in the manual:!Documents/Editing_the_Toolbar.htm!Documents/Launch_Options.htm

For programs that accept drag & drop, you can also drag the viewer's window icon (top left) to the other program to send the current file to it.

Put this button into image viewer toolbar. Change the path of your image editor and icon.
Open with Photoshop.dcf (437 Bytes)

@darkj2k - thanks!

Do you know how I can do the same for the Windows 10 Photos or Photo Editing apps? They don't appear to have an .exe file...

thanks, Leo. Sorry, but I am a newbie with dopus. Can you tell me where/how to use that arcane string? Or point me to a help page where I can learn the subject? thanks.

BTW, if this solves the issue, you can delete the post I made a few minutes ago floating the question up to the subject line.

Instructions for that, and lots of other essentials, can be found in these menus at the top of the page:

OK, I tried following those directions. I opened Customize. I opened a photo in the built-in viewer(since that's where I want the button). I created a New Button, right-clicked to Edit. I pasted

FileType ACTION=shellex SHELLCLASS=AppX43hnxtbyyps62jhe9sqpdzxn1790zetc

into the Function field. I OKed that dialog and the Customize dialog - and the button disappeared.

When I go back into Customize mode, the button appears and Edit shows the Function is still there. OK x 2 again & it disappears again.

What did I miss, please?


P.S. In case it helps, here's a screen snippet:

That should work, and does work here.

Are you sure the button disappeared and isn't just over on the right (or off the side if the window isn't wide enough)? There is a spacer before it which would cause it to be aligned to the right.

Aha! You were right - it was because of the spacer. It did shift all the way to the right - beyond the help button. Thanks. I moved the button back, added a label and tested that it works. Also rearranged so the help button is back on the far right. Thank you.

Now - not that I want to push my luck, but is there a change I can make to the command that would cause Photos to open in Editing mode?

And - it's not directly related - but does dopus have a library of button images from which I could choose something more appropriate?


I don't know of a way to do that, but there may be one.

Edit the button, click the icon, and you'll see a list.

Well I did some hunting and I found this page which describes how to add back "Edit with photos" to the context menu (after removing it). In the Registry Editor script, it has this line:


I'm wondering if that (or other information in that script) gives a hint of how one might do it?

Funny - I tried that before & nothing happened. Now I tried it a few times & it always works... Thanks, doc!

This seems to work, based on that:

FileType ACTION=shellex SHELLVERB=ShellEdit SHELLCLASS=AppX43hnxtbyyps62jhe9sqpdzxn1790zetc

Perfect! That did it. Thanks!