GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Image Viewer Zoom


#1

Hi guys,

I've recently noticed that when viewing a set of images in Image Viewer the zoom buttons don't work correctly.

I open an image (2048x1536) on a screen (1280x1024) and set the viewer to FIT, I then click the zoom in button which goes to 75%, 100%, 150%, 200%, 400% but when I click again the viewer displays 800% in the status bar but the image on screen is actually zoomed out to 100%.

With another image (2896x1936) the same happens although at 400% I get a black screen. Clicking again displays 800% in the status bar but the image is actually shown as 100%.

All images are standard jpg's taken with a digital camera.

I'm not sure if this is a new thing or if I had the same problem in previous versions.

I am currently running version 9.1.1.3.3190.x86 (USB). I have a reason for not using the latest version ATM but that's a separate issue which I'll search for an answer first and post back later.

Any help would be most appreciated.

Regards

Roly


Problem with 1bit TIFFs in Viewer
#2

Further to this, I have just tried the same images on my home PC and they work correctly at all zoom levels.

I'll update my current USB version later today and try again.


#3

Yeah, you can get a black image if you zoom in too far (on a high res image).

Opus asks the graphics card (via GDI) to scale the image but sometimes that fails and results in a black output instead. There's no good way for Opus to know that it failed, though, and the situations where it fails vary from machine to machine (and also amount of free graphics memory, I think).

Converting the viewer to scale in a different way which works around this problem is on the to-do list. It can be fixed (as I had the same problem in my Animated GIF plugin and solved it) but it requires a bit of code refactoring.


#4

I didnt know whether to start a new thread or not about this.

This is still the case with version 10, but on my machine it's definitely a DOpus viewer problem as opposed to a hardware problem.
I dont have a powerful machine, but I can look at images in Windows fax viewer and in other viewers @ up to 1600% or more, but DOpus viewer can't manage the same images @ 800%.
(FWIW the Windows Viewer image is much poorer quality than dedicated Viewers.)

At 800%, it actually shows the image @ 100% - instead of leaving it at 400% (the previous zoom). This is very confusing cause you actually have to press the 'minus' key to get back to 400%


#5

some images cant even make it to 200% in the DOpus viewer -
again no problem in other viewers.

Can anyone confirm this problem or is it only us here in this thread? :slight_smile:


#6

I haven't run into the problem in years. I suspect either the new desktop composition & video driver model introduced in Windows Vista solved it, or having a graphics card with more memory solved it. (My graphics card is about 5 years old now so nothing special by today's standards.)


#7

Anyone else have this problem?
I sill believe it's a DOpus problem as no other viewer I have has the same problem (and I have a few installed).
But, obviously, if no-one else has the same problem I guess then it's a Dopus problem with my specific hardware :frowning: