GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Inconsistent naming of some external HDDs


#1

DOpus does not always give external HDDs their correct (meaningful) name in it's basic / full / system listing.
But it names them correctly under its Computer listing.

My external HDDs are housed in a HX4 enclosure (HDD x 4) that is connected to a USB port by a single cable.
1 of the 4 HDDs is partitioned; 1 partition is named correctly (Y:), 1 is not (X:).
Of the other 3, 1 is named correctly (Q:), 2 are not (V: & W:).
The misnamed HDDs are all 3TB capacity.
Windows Explorer handles the names correctly for all listings.

DOpus handles the name of another, separately connected, single bay caddy correctly (not shown in images below).

The 2nd image below is enough to show the problem.
However, the 1st image gives some extra summary details and context.

In summary, the naming problem only occurs at the lowest level in the full system listing.

It would be good if someone could explain :

  • if I have some setting defined wrongly
  • any available workaround to correct it
  • if it will be fixed in a future version.

Thanks.
And apologies for my earlier rant.
And, Leo, I for one f much much preferred your real pic (previously used); it showed a real person.
:slight_smile:


#2

Correction: The misnamed HDDs that are unpartitioned are all 3TB capacity.


#3

Ok, I corrected the name in Properties (& solved the problem) -- Thanks Aussieboykie (other thread).

  1. right click wrong name -> Properties
  2. it shows the right name in the edit box
  3. Apply button is dimmed --> erase/replace last letter of name in edit box --> Apply enabled --> click Apply

Done.


#4

[b]
Arrrrggghhh!
I spoke too soon.

After reboot, it forgets again... and back to the old problem.

:frowning:[/b]

(I thought that solution seemed too easy)


#5

(In case it helps anyone else, "unpartitioned" here means "just one partition". I got confused at first thinking the drives had no partition at all, until I saw they were all NTFS in one of the screenshots.)

I'm not really sure why this would happen, although the tree and file display do get the names via somewhat different routes. What's strange is that the tree's route is more similar to what Explorer would use, but it's the one that is different to Explorer.

What happens if you fully exit Opus and then re-launch it? Does the tree get the correct labels then?

Also, try turning off Preferences / Folders / Virtual Folders / Native display of 'Computer' and see what the file display (right pane) shows then. That will be using Explorer to populate the Computer file display in Opus, so it will be interesting to see if that matches what Explorer itself displays or what the tree displays.


#6

Hi, leo
Thanks for replying and...

[quote="leo"]

What happens if you fully exit Opus and then re-launch it? Does the tree get the correct labels then?[/quote]

Yes!
That fixes it!
If I start with the "bad" names in the left pane and:

  1. Close DOpus
    2, Open DOpus
    that action corrects the "bad" names.
    Then:
  2. If I reboot (with DOpus initiated at startup), the "good" names are remembered and displayed in the left pane.

Note: That success was achieved by just following your instruction - ie. without needing to rename the drives in Properties again.
(but, of course, I can't say if it would have corrected the problem if I hadn't done that original Properties edit.)

After exiting DOpus fixed the problem (I can see the logic of doing that now but it never occurred to me when I had the problem), I :
- turned off the setting [i]Native display of 'Computer'

  • Exited DOpus
  • Started Dopus
  • Names are still "good".
    - turned Native display of 'Computer' back on
  • Exited DOpus
  • Started Dopus
  • Names are still "good".

So it looks as if it's got the message now.

Thanks a lot, leo.
You always have every synapse firing and give the fix straight away.

:slight_smile:


#7

First time I've used the FX4 enclosure again.
Problem is back as soon as it starts up.
Previous "fix" was just temporary.

:frowning:


#8

The correct drive labels are retained for all external HDDs as long as the external Hx4 enclosure is not turned off.
When turned off and then turned on again later, it reverts back to partial labels.
Note: Once again, this occurs on externally housed SATA HDDs that have only 1 3TB partition.
It's fine for 2TB HDD or 3TB trhat has 2 partitions.
So it looks like any partition that exceeds 3TB is the problem, whether the "Native Display of Computer" is turned on or off at the time the HX4 starts up.

Any other insights?


#9

Sorry, I meant "So it looks like any partition that exceeds 2TB is the problem, whether the "Native Display of Computer" is turned on or off at the time the HX4 starts up."


#10

Fully exit Opus, then restart it again. Does the tree show the correct drives?

If so then the problem could be that the drives do not supply the correct names if Opus starts too early during boot, and do not report that their names have changed when they do become ready, so the tree is caching the drives as unnamed.

I doubt the size of them has anything to do with it directly. Maybe it means they take longer to become ready or there's a bug in the enclosure with how it handles larger drives, but Opus itself does not care at all how large the drives are, especially when just asking the operating system for their names. And Opus is able to get their names sometimes, so the problem must be with the hardware/drivers supplying the wrong names sometimes when Opus asks for them.


#11

[quote="leo"]Fully exit Opus, then restart it again. Does the tree show the correct drives?

If so then the problem could be that the drives do not supply the correct names if Opus starts too early during boot, and do not report that their names have changed when they do become ready, so the tree is caching the drives as unnamed.

I doubt the size of them has anything to do with it directly. Maybe it means they take longer to become ready or there's a bug in the enclosure with how it handles larger drives, but Opus itself does not care at all how large the drives are, especially when just asking the operating system for their names. And Opus is able to get their names sometimes, so the problem must be with the hardware/drivers supplying the wrong names sometimes when Opus asks for them.[/quote]
Yes, but I better qualify that.

The HX4 is started on demand.
It's not running all the time.
I might need those HDDs no more than every 2 or 3 days for 30 mins; because, mostly, they are for back-ups.
So, Dopus begins at Windows startup - it is already running when I turn on the HX4.
When HX4 is initally turned on, OPus tree shows the problem in previous screenshots.
Always the same HDDs have the problem; never any variation.
Then
If I exit Opus (completely) and then restart it, then it shows the labels correctly.

Sooo...

  • it shows the labels correctly if the HX4 starts up before Opus starts
  • It never shows them correctly if Opus starts up first.

That's the behaviour whether or not the Native display of 'Computer' setting is checked or not.

So, I'd guess that Opus ius not "forgetting" because it isn't getting shutdown correctly.
The problem seems to be the info Opus gets about external HDDs when they are started up.
When a new HDD comes online, maybe Opus needs to go back to explorer and get all the details.

Anyway... as said, I suppose I can exit Opus before I start the HX4 (since its rather rare) and hope I don' have several listers open at the time or something...
:slight_smile:

Ok, thanks for all the help, Leo.
At least I know how to do the workaround (=stop/restart Opus).
:slight_smile:


#12

If the drives are turned off, why do they appear at all? Windows shouldn't even know they are there until they are turned on and mounted.


#13

[quote="Destry"][quote="leo"]Fully exit Opus... The HX4 is started on demand. [/b]It's not running all the time.
I might need those HDDs no more than every 2 or 3 days for 30 mins; because, mostly, they are for back-ups.
So, Dopus begins at Windows startup - it is already running when I turn on the HX4.
When HX4 is initally turned on, OPus tree shows the problem in previous screenshots.
Always the same HDDs have the problem; never any variation.
Then
If I exit Opus (completely) and then restart it, then it shows the labels correctly.
:slight_smile:[/quote][/quote]

Leo, I'm not talking about when the HX4 is off.
The whole issue is about what happens after the HX4 is turned on... what Dopus displays then.

Obviously, when its turned off, Windows and Dopus display nothing. The 2 wise monkeys... see and speak nothing.

Just like if you have a thumb drive for portability. Use it on demand.

:slight_smile:


#14
  1. HX4 external HDD enclosure is connected to PC via USB cable and is usually offline;
  • Dopus runs at Windows startup;
  • HX4 is never turned on when Windows starts.
  1. After Windows startup, when HX4 still turned off, Windows Explorer & Dopus display nothing.
  2. Some time after Windows startup, HX4 is powered on.
  3. Windows Explorer displays all (4) drive labels correctly.
  • Dopus gives generic names to some (2) drive labels and correct labels to some (2) others.
  1. Dopus is shut down (completely)
  2. Dopus is restarted.
  3. Dopus now displays correct labels for all (4) of the external drives.

#15

I guess I should have added that, if the HX4 is turned in before Windows (and therefore Dopus) start, then - after startup - all 4 drives have correct labels in both Windows Explorer and Dopus.
(but, in practice, the HX4 is not wanted all the time so this situation is irrelevant)