GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Installation failure


#1

I'm installing Directory Opus 10 to a 32-bit Windows 7 PC. The installation runs almost to completion (the shortcut appears on the desktop and the status bar reaches the end), but just then I get an error message and the installation seems to undo itself. The desktop shortcut disappears, and C:\Program Files\Directory Opus\ has no files, only the folder \VFSPlugins. (Yes, I changed the installation folder. No, that makes no difference.) The message is:

Unhandled Exception
Error Number: 0x8000FFFF
Description: Catastrophic failure.
Setup will not terminate

I've tried this 3-4 times, re-booting in between. Any ideas where to look? This is a company PC. Who knows what policies they have installed. But I can install other software just fine.

Steve
College Park, Maryland


#2

If you haven't already, please see the Problems installing Opus guide, in case anything in there is helpful. The exact error message isn't in the guide but some similar ones are and it's possible one of the suggestions will still be what you need, or might provide an idea of what to try.

If none of that helps, using Process Monitor (there's a link to it in the guide) to log what the installer does up to the failure point should provide us with a good idea of what is failing.


#3

Leo,
Thank you for your suggestions. I have run Process Monitor just now, but the result is beyond my skill level. I can send the its log file (*.PML), but I see no place to attache files here. Other clues:

  • I had the Help Desk tech give it a try. I think I have admin privileges on the PC, but he certainly does. Same result.
  • I ran the installation on an XP box. Same result.
  • I ran the installation on the Windows 7 box not logged into the network. Same result.
    I reviewed the knowledge base but found nothing useful there.

What's next? Does the publisher support this? Are you their representative, or just a volunteer? (Thank you, either way.)
Thanks,
Steve Beste
College Park, MD


#4

Thanks for trying so many things, and creating the PML log.

I'm part of the Opus development team so you're in the right place.

Please zip up the PML log and send it to me via a private message. (Click the "PM" icon below my name, on the right.) There should be an attachment option below the message form.

(You can also attach files to public forum posts, by clicking "Full Editor" or "Post Reply"; it's just not in the Quick Reply form. However, PML logs may contain some details you don't want public, like which other software is on your machine or computer names, so a private message makes more sense anyway.)

Alternatively, if you have trouble with the private message form, you can email the zip to leo@gpsoft.com.au which will reach me as well.

I'll take a look at the log and see if it indicates a likely cause.


#5

Hi Steve,

Have you tried re-downloading the installer? Since you tried on different OS's (local and network accounts), sure sounds like it's the installer (unless of course you are downloading a new copy on each OS).

Have you tried Right-click -> Run As Administrator? Sometimes even Admin accounts need to do that.

If you have, then never mind... you're in good hands with Leo and/or Jon :slight_smile:


#6

John,
Those are both excellent suggestions. Neither opened the door, however. With great hope, I re-downloaded the software (Windows 32-bit) and re-ran the installation using the Run As Administrator launch. But same result as before. I will send the PML log to Leo.
Thanks,
Steve


#7

Hi Steve,

The installation failure seems to be caused by your machines being locked-down in a way which prevents shell extensions from being installed.

Specifically, registry values cannot be added below HKLM\Software\Microsoft\Windows\CurrentVersion\Shell Extensions\Approved.

Here's an animated gif which compares the Process Monitor log for a successful install versus the log you sent, highlighting where the two diverge:

leo.dopus.com/posts/OpusShellExt ... lError.gif


#8

Leo,

Let me talk to the IT security people here. I'm sure this is their doing. Thank you so much for narrowing it down. (And your animation is VERY effective. How did you do it? I could use it when supporting my own users.) Anyway, please close the ticket.

Thanks,
Steve


#9

I took the two screenshots, put them in Photoshop, moved the columns around slightly to line everything up, and saved it as an animated gif.


#10

Solved. In the end, I turned off the Windows 7 firewall. It installed fine. Then I restored the firewall and I'm in business.
BTW, the same thing happened at work where they use McAfee 4.6.0.2292. Turn it off and Directory Opus installs fine. On, it doesn't. As you noted, the firewalls are blocking the installer's attempt to create a shell extension. My home PC is a pretty vanilla box. (Win 7 64-bit). I should think that all Win 7 users would be having this problem. Perhaps you guys could trap this error and put up a useful message. The workaround is so simple. Anyway, case closed.
Steve


#11

If they were then we'd have more than one report and would definitely know about it. We'd be seeing it on our own machines, too. :slight_smile: And hundreds of other products which include shell extensions would also be failing to install.

It is very unusual for those registry keys to be locked down in that way. It's definitely not part of the standard Windows install, and the Windows Firewall should not affect those registry keys at all. (Something like Windows Defender or antivirus tools might, but not Windows Firewall.)