Installer fails when updating if you select "No, I will restart my computer later."

Just thought I'd mention I've used your software for a long time and always maintained the latest version, however whenever I update it fails if I select that I'll restart later.

Would be great if you can fix this!


Fails in what way?

When I restart it hasn’t installed. The application still says the old version and continually prompts me to upgrade. It isn’t until I run the installation again and select to restart that it works.

That's quite odd since the only difference at that point in the install is when the restart happens.

Is there anything installed on your system which affects other programs installers/uninstallers, or the registry? (e.g. "Uninstaller" products, or registry cleaners.)

I don’t have this with any other installer or updates. I have no registry cleaners, antivirus (beyond the latest windows 10), or uninstallers or similar. I run a very standard installation. This also happens on my laptop.

This has happened for a long time. I reckon over a year or so. Because it’s no big deal to get around it I’ve never bothered reporting it. I just make sure I do it right before shutting down.

I’ve also formatted and reinstalled a few times and it still happens.

Quite strange. I'm not sure what would cause that on a clean system like that. I delay the reboot quite often when updating myself without issue.

We're thinking about making some changes to how the installer works, which should avoid this entirely (at least in most cases), so hopefully it won't be an issue for you much longer.

That’s great, thanks!

It’s not a big deal, just annoying with every update.

1 Like

I just wanted to drop by and update this ticket with the fact that since you've updated the installer this is completely resolved.

I used to hate getting the update messages and having to schedule when I would install and restart, but now everything works seamlessly. I never have to restart just to apply an upgrade.

Keep up the great work!