Internal picture viewer setting / association bug?

Guys, under Win 8 x 64 if I turn off 'Use internal picture viewer for:' and then double click on a JPG in a lister two things happen:

  • a new blank tab opens
  • Sync Center in the control panel pops open

I guess this has crept in with the latest beta?

Use the Open With menu to assign a (non-metro) app as the default viewer.

(Metro ones make work as well, but if it still doesn't work, try a non-metro one.)

Already done that, I have ACDSee as a viewer, makes no difference. If I have ACDSee set as the viewer and double click on a JPG within the lister DO still tries to use the inbuilt DO viewer. This is why I was looking at changing the option to see if it woudl resolve that issue.

Isn't that a separate thing? If you don't want the Opus viewer to be used, turn off the Preferences option (then use Open With to make sure ACDSee is the default viewer, if that's what you want in addition).

The Sync Center thing seems to happen for things that don't have filetypes assigned to them on Windows 8, so another thing to do is make sure the .JPG filetype exists.

If you still have problems, please run FileTypeDiag on the .jpg extension and post the output here. (It may take me a couple of days to look at the output, at the moment.)

It is indeed, I was not long awake when that first post was made.

The DO viewer is turned off as an option, Open With has been used to set ACDSee as the viewer, the JPG file type exists. Using Explorer from the WIn 8 desktop JPG files open fine with ACDSee it's just the lastest beta of DO that this seems broken in.

Okay output from FileTypeDiag attached.
JPG.txt (279 KB)

Tried with latest Beta on Win8 x64 - activated uses internal DO viewer, deactivated opens Metroviewer. Did you also check "control panel > default programs" (some progs don't assign all filetypes correctly under Win8 and "open with + set as default" doesn't change it then)?

Yep, tried that as well, no difference.

Does this still happen with this morning's new beta ( It's fixed a similar problem for someone else, but I'm not sure if both things are the same or if there were two separate issues.

I'll know when I get home tonight - fingers are firmly crossed!

Okay ACDSee now works again but i did have to turn off 'Use internal picture viewer for:' to get it to work. I can live with that though!

Cool! (and of course :slight_smile: if you want to use an external viewer on double-click then turning off the option to use the internal viewer on double-click is needed)

Yep :slight_smile:

So happy once again!