GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Internal WAV player has a fade in

I'm an audio guy and DOpus is great for organising sound files, except that there's a horrible fade-in when using the internal WAV player. Can this be removed? It's an absolute killer for some of the work I do. I need the sounds to play exactly as they are.

I don't think it's something we do, at least intentionally, and there's no fade-in here when I play a wav file that I can detect, assuming we're talking about this player:

image

Yes, that one. I've never noticed it before so I thought it was something new. I've been doing a massive export of short audio clips for something and the player was making me think that the front of each render had been chopped off. I've got none of those daft Windows audio enhancements switched on. After many setting changes and redoing the export, I eventually loaded a WAV into Audition and it was fine. In VLC it was fine. Which audio device do you use for playback? Is it the default non-exclusive WASAPI device?

We don't talk to the audio device directly. Playback is through the old, very simple / high level Windows MCI API: https://docs.microsoft.com/en-us/windows/win32/multimedia/mci

And guess what? It's just stopped doing it. What the...?

I can feel a new plugin coming on.... :wink: I haven't done one for about 10 years. My original WAV thumbnail plugin was supposed to expand into a player as well, but I never got around to it.

Thanks for the swift responses.