GP SoftwareTwitter
Opus FAQsManualCommandsObjects

iPhone X iOS 13.3 Problems copying files (Opus + Explorer)

When I connect my iPhone to my PC, I see the folder structure under Apple iPhone in Directory Open, with all the relevant subfolders. All the files contained in the folders appear in the lister window.

If I have a split screen and select a group of files from the iPhone and drag them over into a local folder on my PC, about 1/2 the time nothing happens. No file move dialog appears, no files are copied.

I have toggled the mtp_enable flag, this does not have any effect.

Is there any suggestions or known issues with the current version of Opus (12.19) and iOS 13.3 in this regard?

Is it working if you do the same thing from File Explorer?

Back in Opus, try using the Copy Files button rather than drag & drop as that sometimes works better if something is blocking drag & drop.

Thanks Leo. I tried the Copy Files button and nothing happens. I selected a lot of files (786) and nothing. I tried selecting a small subset of files (100 jpg images) and it got about half way through and suddenly quit without warning. I'm starting to think maybe something is funny with the phone storage?

I tried File Explorer and it was basically the same, itv started to work (dragged one the folder under DCIM to the desktop). It started working but after about 1 minute it terminated with an error window about "unable to reach device".

So it doesn't appear to be the software but more likely something on the phone. I'll figure out another way to xfer images off and into my PC.

Thanks!

Marc

1 Like

It might be worth trying a different cable and/or USB port.

On Android it's usually easier to install an FTP server on the phone and download files wirelessly via FTP, but I don't know if Apple lets you do that.

Problem Solved!

On the iPhone, Settings/Photos and select Keep Originals (default is Automatic which performs some sort of compatibility check or conversion, I'm not sure but turn it off by selecting Keep Originals).

Reconnect your iPhone and it now works without any issues.

Thank you again for your responses, I greatly appreciate your help.

Marc

Thanks for letting us know. I've added that to the MTP FAQ in case it helps other people with the same problem.