GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Is there a quicker way to set background images?

Once again, my main music folder and all subfolders lost their background image, due to some drive letter change, which sometimes happens with my SSD drive. Is there a quicker way to set the images, rather than going through the folder options? I couldn't find no raw command for that. Maybe something like "Prefs Setbackground=xyz.jpg" would be useful, like we already have Prefs ADDBACKGROUND.

Easier to fix your config than re-create it, if you still have the config there and the folder formats are just pointing to the wrong drive letter.

  • Fully exit Opus (via File / Exit Directory Opus).
  • Open C:\Users\<username>\AppData\Roaming\GPSoftware\Directory Opus\Formats\folders.off in your favorite text editor.
  • Save a backup somewhere.
  • Do a search & replace of A:\ to B:\ (or whatever the letters are).

Hmm, that's the strange thing. I have reset the drive letter, of course. But for some reason, it didn't work for the backgrounds. The file is still present in the right place, i have checked that.

I also see some "ghost" entries of older versions of the same image, which have no corresponding image, which would show in the preview window. The editor doesn't tell me, where the images are pointing to, but i know i had that JPG in different places. Would be nice to have an edit function, to erase those entries.

I have also tried to set the image in the main folder, and since it's always the same backdrop, to make all subfolders inherit that setting through the "save" / "for all subfolders" dialog, which didn't work.

Has the drive the image file is on changed?

(As opposed to the drive/folders the image file is applied to.)

No. It used to be on N:\blah, was G:\ inbetween, then i've changed it back to N:, which should work normally. But now they are all grey standard backgrounds. That's funny.

Ok, i found the reason. I had to restart Opus :blush:. Now the backdrops are back. I didn't think of that, because i had the drive letter fixed quite a time before i even opened my music folder. So it had to be re-initialized, or something like that.

:thinking:

1 Like

That's probably why @Leo listed that first bullet-point item.

You're right. Thanks.

1 Like