Issue mounting ISOs?

Tried mounting an ISO, and the status bar flashes a few times as though something is happening, however the ISO doesn't mount.
Tried opening it with windows explorer, and dopus opens instead.

I believe that in v12 it would mount to a new drive letter.

How are you mounting them? (There are several ways it can be done.)

Normally double click on the file, though as this doesn't work I tried using the context menu "Mount" option, which isn't there, so tried "OPen with --> windows explorer". These all used to work with V12, I seem to remember.

FYI I downloaded the first .reg in this link which then allows me to open the iso in a drive using windows explorer, however dopus still does not mount the iso, and if I choose "open with windows explorer" within dopus it open an explorer window with the recent files.

Try making Explorer the default handler for ISO files. Double-clicking them should mount them then.

Make sure ISO hasn’t been turned on in Opus’s VFS plugins either. That will try to open them like archives rather than actually mounting them as a real drive everything can access.

Changing the windows setting for default program to open ISOs to explorer worked, as you suggested. Might prevent some people having the same issue (and wasting your time) if it's possible for dopus to open them natively.

Thanks for your help.