Issues with DopusRT /argsmsgbox in Terminal

For the past few days I've been having an issue with using /argsmsgbox to see contents of variables such as {filepath$}, running:

dopusrt.exe /argsmsgbox {filepath$}

Gives me a message box with the text:

-encodedCommand ZgBpAGwAZQBwAGEAdABoACQA -inputFormat xml -outputFormat text

I was making do with dopusrt.exe /acmd Clipboard SET {filepath$}
As an alternative and it was working but now it too just set the clipboard to:

-encodedCommand ZgBpAGwAZQBwAGEAdABoACQA -inputFormat xml -outputFormat text

I also tried dopusrt.exe /argstoclip {filepath$} and get the same wierd string in pushed to clipboard.

Any information on this message would be appreciated. Could not find anything via search. Thanks.

Are you running it from a button? Try dopusrt without the extension.

Running the latest installer on top of your current installation might be helpful, too.

Thanks @lxp

I am running latest update 12.28
I am running it from an external program, windows terminal.
Just now I tried using the old windows command prompt with a file selected in Opus. Am not getting that message of encodedCommand ZgBpAGwAZQ... anymore but {filepaths$}. See picture below.
I also tried your suggestion of just DopusRT. Still not seeing the path

It takes two to tango :wink:

"C:\Program Files\GPSoftware\Directory Opus\dopusrt.exe" /acmd dopusrt /argsmsgbox {filepath$}

1 Like

I'm lost here. {filepath$} only works in Opus buttons. Or is that also the syntax for variables in Terminal as well?

What are you actually trying to do?

Why are you running dopusrt.exe /argsmsgbox from Terminal?

Hey! the good news is your suggestion pretty much worked. it will only work in CMD shells such as the old command line prompt or a CMD prompt in Windows Terminal. It will not work in PowerShell, it bring up a ArgsMsgBox window but with the text:

-encodedCommand ZgBpAGwAZQBwAGEAdABoACQA -inputFormat xml -outputFormat text

I will do some more experimenting in hopes of finding out why this is

Thanks so much for bearing with me through this!

This started is a simple need to see what these variables mentioned here contain Codes for passing filenames, as I am looking for a way to pass active paths or selected files paths from directory opus windows, tabs, source, destination etc to other programs (especially PowerShell and Command line tools) without writting .xml files to disk by using the DopusRT /Info command.

A similar way to how the internal commands in decretory opus can directly access paths via variables such as {filepath$} or {filepathdest$}

Reading this thread here How can I see what my opus scripts resolve to , lxp suggested to use:

Yes. Use a button with

dopusrt /argsmsgbox {filepath$} {filepathdest$}

Use F5 for quick debugging while the command editor is open.

I figured I can just invoke the DopusRT cli tool with his suggestion, since the docs says that's what argsmsgbox is for:

dopusrt /argsmsgbox {filepath$} {filepathdest$}

but invoking the above just brings up a message box with the text:

-encodedCommand ZgBpAGwAZQBwAGEAdABoACQA -inputFormat xml -outputFormat text

Outside of Opus, those variables don't mean anything and won't work.

Garbage in => garbage out. {filepath$} has no meaning to Terminal or PowerShell. It only means something inside of Opus.

I was hoping you might have a suggestion for an alternate means. How can I then go about getting external applications to accesss the data of these perticular variables in Directory Opus.

I really need interoperability between Directory Opus and a number of other tools and accessing these variables to me seems to be a key starting point.

Do you think I shold just take to scripting in Opus and create my own variables that are essentially the same as these Opus variables? but then wont I run into the same wall?

My apologies if these questions seem redundant. Vey new to all of this.

You already found and mentioned the proper way to do it, via dopusrt /info.

Just call these tools from a normal button, Opus will hand over all the codes. If the tools need to run in a dos command shell, set the function to MS-DOS.!Documents/Advanced_Command_Editor.htm

1 Like

Okay I will keep this in mind. thanks allot guys