Items in Context Menu not working (due to PC Reviver)

The Program "Everything" appears in the right click menu (to search for everything). However, when using from within Opus nothing happens & the "Everything" program does not start. This can't be blamed on the "Everything" program because it works from within "Q-Dir" & "Total Commander". Do I need to chage any Opus settings to get it to work or is it a bug. "Everything" is available free from:
THanks Ed4B

Win10.0.19044 Pro (x64) | DOpus 12.29.1 Pro | Everything (x64)

No issue here. I don't know of any particular settings within DOpus itself. That said, there could be a context menu conflict.

If you haven't already, something here may help: List of FAQs organised by topic

Are you running Everything, Opus, or any of the other tools you tested with elevated? That could break things one way or another.

Very many thanks. Turning off admin rights in both Opus & Everything has partially solved the problem. Now if in the left hand pane I have a list of my drives (as in This PC) I can right click on one of the drives & search Everything will work. However, if in the right hand pane I open up the drive & right click on one of the folders search Everything does not work. It does work from within Q-Dir so I can't imagine it's a setting within search Everything at fault.

By "left" and "right" panes, do you mean left and right dual file displays, or do you mean the folder tree and the file display?

Left & Right dual file displays.

I'm not sure what's going on there in that case. As far as Opus is concerned, there isn't any difference between right-clicking in those two places.

The problem only exists on folders & sub-folders within a drive. I have a small video of the screen when this happens - can I post that somewhere?

Attachments to posts can be up to 100 MB, I think.

Yes, you can drop MP4 videos directly on to the post editor.

Or upload them to YouTube and paste the URL, if you prefer.

From the video you emailed us, and what you said in your last reply, it looks like the problem isn't tied to the left or right pane but which folder (or type of folder) you're in.

That makes more sense. The context menus for drives under This PC are different to the ones for normal folders/sub-folders.

A Process Monitor log of what happens when you select Everything in the context menu might be the best way to see what's going on.

If you make a log, please turn on all the logging options/icons and don't filter out other processes, since we need to see if Everything.exe is being run.

Thanks - I have sent the log file.

I can't access it as it has been restricted to another Google account. I sent an access request earlier today which you should have received via email. (Please check the spam folder in case it's there.)

Thanks for re-sending the log!

Based on what I can see in there, it looks like a shell extension may be crashing (possibly due to antivirus, which is doing things in parallel, but I can't tell for sure if it's that or something else).

A couple of things to try:

  • Turn on Preferences / Miscellaneous / Windows Integration / Hide Windows items on file context menus (shift overrides) and try the menu again. If it appears then, it confirms the problem is happenign when trying to query a shell extension.

  • If that helps, try turning it off again, then disabling all antivirus to see if the menu works then. That will tell us if it's involved or just coincidental.

I have done as requested. When turning on Hide Windows items........ the Search Everything & most other items are removed from the context menu on folders but not on disk drives.

Apologies, I was looking at too many things at once earlier and got two different things confused. That wasn't a good test as, of course, it just hides the item.

I had another look at the log and can see Opus trying to launch Everything.exe, but can't see it ever start. (In fact, there is no activity from Everything.exe in the log at all. It's as if it isn't there or never launches.)

Two security tools look like they may be worth checking. GlarySoft Process Manager (GUPMService.exe) accesses the Everything.exe during and shortly after Opus tries to launch it. That is a tool which says it can block software from being launched, so maybe it's stopping Opus from launching Everything (when launched via some methods but not others).

Panda Security is also doing some things involving Everything at around the same time, and might also be blocking things.

I would also double-check that Everything.exe is not running as administrator. (It's OK for the service to run as admin, but the UI process you can actually see and interact with should not be running as admin.) If you open Task Manager, go to the Details tab, and turn on the Username and Elevated columns, it should look something like this:

The first one is the service, which is running as SYSTEM and elevated. The other one is the UI process, running under my user and not elevated. It should look similar.

It may also be worth a try to exit the Everything.exe process that's running under your name, confirm it's no longer in Task Manager's Details tab (only the SYSTEM one should remain), and then try the context menu again, in case the issue is with talking to the existing process rather than launching a new process.

1 Like

I have tried everything you suggest here, without success. I have also sent you a new logfile created after the uninstalling Panda & Glary Utilities in the hope that helps.

Thanks for trying those, and sorry they didn't work. Thanks also for the new log. I've been through it but can't tell what's going wrong.

Something else we can try is to check the registry and file types config in case something in there is confusing Opus.

  • In Opus, go to Settings > File Types

  • In the menu at the top of the window which opens, use File > Diagnostic


  • Choose the Folders option


  • Click OK and it should create a zip file on your desktop. Please email that to us.

Many thanks, and sorry it's taking so long to solve this.

File sent (to crashdumps) as requested.

The diagnostics looked normal, but gave me a list of software to try installing. After installing about 20 programs I found the cause to be PC Reviver.

As soon as PC Reviver is installed, the Everything context menu item stops working in Opus.

If you use RegEdit to go to HKEY_CLASSES_ROOT\Directory\shellex\ContextMenuHandlers\PC Reviver and modify the (Default) value there (e.g. add not_ to the start of it) to block its shell extension from being loaded, the menu starts working again.

I don't have any experience with that one but "Cleaner" applications usually cause more problems than the solve in my experience. This one also seems to be considered malware by a few antivirus tools, although it's the first I've come across it and they may be false-positives. Malwarebytes has a detailed guide on removing it, however, and it's said to try to display ads, harm performance, and do other unwanted things, so if it was me I would probably get rid of it entirely rather than just disable the shell extension that's causing problems.