Junction Target not show in Description

For some reason I don't see the target in the description column for junctions. Is this behaviour optional now? how can I activate it?

Does the General > Target column show the targets?

If it does, check if you've changed Preferences / Miscellaneous / Advanced [Information Display]: desc_show_info to remove target details from the Description column.