GP SoftwareTwitter
Opus FAQsManualCommandsObjects

KODC theme... right clicking in views is tough to read


#4

Try toggling Preferences / Toolbars / Appearance / Use Office 2003-style for toolbars maybe.

How did you get the file context menu text to be white in the first place? :slight_smile:

(Assuming that is a file context menu. The image is so scaled down I can only really make out that it is some kind of menu, without seeing exactly what or how it is being rendered.)


#5

White fontcolor (toolbar) meets standard white menue background. You can only solve it using bg-pic also for menue (which might look ugly when tiled) or using own style mentioned above (which has got other disadvanteges).

It's generally a problem using darker toolbars, I really would like to have a separate color-option for menus (font and bg-color) and also a customizable selector.


#6

...meant separator, not selector, sorry!


#7

When I set the toolbar background/text colors it doesn't affect the context menus at all for me.

(Prefs / Display / Colors & Fonts / Standard Toolbar -- Is that what you're using? Maybe I'm looking at the wrong thing.)


#8

No, edit mode. Working on a darker theme and when choosing darker bg-color and white textcolor you have also a darker menu, which looks not good due to design of menus (borders, separator,...). When using a darker BG-picture instead of color and turn off for menues standard is white menu with white text. So a separate option for menue bg- and text-color (toolbars) would give more felxibilty "designing" Dopus.


#9

[quote]How did you get the file context menu text to be white in the first place? :slight_smile:[/quote] Great Question.. no idea. i just saved his theme, and then opened it, and it defaulted to this :frowning:

Cropped image. making it larger.. You will notice on screen 1, that when i right click folders it shows the options nice and clear.

and in second view when right clicking it's unreadable

Thanks!


#10

I Understand what Sasa is saying. I had the same troubles with my dark toolbars. If you have a dark toolbar and want the font of all buttons to be white, you set it to white on the Label Color for that toolbar. But now you just turned all submenu items to white as well and the default submenu item's background is white'ish. turning on "Image is inherited by submenus" (assuming you are using an image) isn't enough because some images used on the toolbar don't tile correctly or just look darn right wrong.

To fix this, on the selected toolbar, leave the Label Color alone or set it to what you want the submenu items to look like. Then you have to edit each button manually (the root toolbar buttons) and change them to use a lighter color text.

I was going to request this get changed is someway but got lazy and didn't want to give the opus team any more work to do. But now that Sasa brought it up :slight_smile:

But this wont fix xtacbyme's problem (I think). The above Sasa problem is only on toolbar's and their submenu's, not right-click context menu items. I have no idea how xtacbyme got that, and for Files only :slight_smile:


#11

i don't either.. just download trial of Opus, then immediately downloaded KODc (cause i like black windows) and have yet to be able to get this right click viewable. :frowning:


#12

can I do a backup of my set up, then upload it, and another person could restore mine.

I had the same problem when i first started using this theme with my menu bar but that Leo and i got fixed. this is the only buggy thing i need to weed out.


#13

Another example... this time it's in view 1.. and i cannot see where rename is/We're making swatches from scanner, and i need to rename all these.


#14

Ah, looking on first picture I thought toolbar-menu was mentioned..., can't confirm with context-menu, could only caused by custom styles in prefs.


#15

xtacbyme, Do you get the same problem in Windows Explorer?


#16

i do not...only happens with this theme.

out of curiosity how do we disable opus? to do quick tests like that? i had to goto services and disable auto startup. is there a quick way to shutdown opus?
Thanks


#17

See FAQ's: [quote]How to Exit Directory Opus]


#18

I just go to Start -> All Programs -> Accessories -> Windows Explorer

No real need to shut Dopus down


#19

Just tried the Theme. I get the same thing, but also happens to Folders as well as Files and Drop-down menus in toolbars.

I think the options you want is Preferences -> Display -> Colors and Fonts -> Other Colors -> Standard Toolbar. Change the Text to Black. This fixed all the problems. But now you have to go to each button and fix the color to be white text. If you change the entire toolbar to use white text, then you'll run into submenu's taking the same white color so you'll end up with the same problem. It's the problem I described above. So now you have to edit each button separately instead of a faster toolbar option for submenus.

Kind of weird, I had to set the above Standard Toolbar from "Use system colors" to my own color. Fixed everything. Now when I change it back to "Use system colors", it's working fine.


#20

When I set the toolbar background/text colors it doesn't affect the context menus at all for me.

(Prefs / Display / Colors & Fonts / Standard Toolbar -- Is that what you're using? Maybe I'm looking at the wrong thing.)[/quote]

I think I was doing something wrong yesterday. I can reproduce the problem now and I think it's just a mistake on my part in the menu-painting code. It is using the toolbar text colour in menus when drawing them with visual styles, when it shouldn't be.

I'll get that fixed today for the next update.

You can turn on Preferences / Toolbars / Appearance / Use Office 2003-style for toolbars as a workaround for now.


#21

Leo/Ktbcrash.. will this update fix my issue as well? or only Sasa's issue?
Thanks


#22

I meant your issue. (I think they are the same though.)


#23

great news..ty!