Label Assignment - FTP Opening Connection

After creating (my first) Label Assignment with a wildcard, to label anything modified within 1 day, it tried to access FTP sites, throwing errors for ones that are not available.

It keeps trying until the label is unchecked and applied.

The only related option I see is in Favorites and Recent -> Enable storage in the file system (NTFS volumes only) which is checked.

What is the exact label definition you created?

Which action triggered that? As soon as you clicked OK in Preferences, or something else?

Does it only happen if the folder tree is visible? Or if FTP sites are visible somewhere (e.g. have you added a list of FTP sites to your toolbars or anything like that which might display them all the time)?

It happens right away when clicking apply to enable the Assigned Label.

I did it again now to test. With prefs open to Label Assignments, I enabled the filter DTb2001d -> Apply and right away 8 dialogs open within a few seconds saying " Opening Connection. Try 1" all the same IP, it's local. This time I let them time out, all went to "An Error occurred reading folder: Cannot connect to site..." There's a few ms delay for each.

So I closed 4 of the errors - right away 4 more " Opening Connection. Try 1" opened. It never does a try 2, just times out to the other error, see image.

As long as I have the DTb2001d enabled, these 8 errors will stay open, retrying when I hit OK to the error.

They errors sat there a few minutes while I typed here, then I unchecked the filter again and waited a minute. The errors stayed. When I click OK on each, they close and stay closed.

I have not used the FTP in 2 months or so. There's several bookmarks, none have any indication of autorun or anything different. The particular IP that opens is

The pic has all my labels, I made the others yesterday, they have no rules, only the new one does.

I have 7 FTP sites setup, 2 are no longer valid IPs. But only the second one in the list shows the error.

I'll do some testing...

20210412 FTP label 2

20210412 FTP Error Cannot connect to site

20210412 Assigned labels

When I changed the site IP, it kept showing the old IP. So I exited completely, opened again, same error.

Exported sites, removed them all, restarted dopus, same error.

Also removed lister layouts with network tabs, but still getting the error.

Backed up everything, restored only MISC. Same issue.

Created new filters of different types. Every label filter triggered the FTP, other types did not.
20210412 Assigned labels Tests

Solved by removing all Favorites links to FTP.

We'll make a change after 12.24 to stop the tree's Favorites branch using label filters, since they'll cause more problems than they're worth there.

(BTW, it's better to use the FTP menu, and FTP branch of the tree, for FTP related bookmarks.)

FTP next to local folders helps to stay focused on what I'm doing vs how to get there...

Is there another way to shortcut to the FTP bookmark?

Fair enough, if it's working for you then there's no reason to change unless you run into problems.

Thinking about it, Favorites will now point to FTP Address Book entries (rather than duplicating their details like username and password), as long as the favorite is by connecting to an address book entry and then adding the current folder to the favorites. As long as you do it that way, on a recent version, there shouldn't be any disadvantages.

Turning off Preferences / Folder Tree / Appearance / Use configured file display colors for tree items should also give you a temporary fix for Label Filters causing FTP sites in the Favorites list to connect, if that's any help. (Of course, you'll then not have colored folders in the tree. Once the fix is out you can have both again.)