GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Lag in Viewer Pane (due to .ass subtitles)


#1

Hello, I tried both plugins, active-x and movie plugins, both suffering same issue.
It causes the entire DOpus to freeze until the file selected was finally loaded into preview plugin.

When selecting videos files to preview, it doesn't have any kind of issue.
But until i selected a file that has a separated .ass subtitle file that has the same name as the video, it will freeze the DOpus for few seconds until the preview is shown.
when looking it closely while simulating the issue.
Selecting the video files, i can see the plugin UI show for like 0.5 second, then it dissappears and DOpus freeze for few second.


#2

Try the WMP Preview Handler (not ActiveX control), which you can enable via the ActiveX+Preview+Office+Web plugin's configuration window.

Disable the Movie plugin as well.

The WMP Preview Handler is click-to-play, so it should not suffer from that problem, even if the video components on your system are suffering from it when a video is played via the other two methods. (Those video components are not something we have written or support ourselves, so if they're having problems with .ass subtitles or particular files, we're the wrong people to tell. Opus just uses whichever components are installed on the system for video playback.)


#4

hello,

thanks for the suggestion, it did solve freezing issue.

but now by disabling movie plugin.
The non-editable properties in metadata pane, appears to be empty.
image

if i enable back the movie plugin
image


#5

Please close this.

I think this might due to my pc or codec related issue and not related to DOpus,
As i manage to fix this by setting everything default to DOpus,

I installed assfiltermod, and config via assfiltermod to disable ASS subtitle file from auto loading.