GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Laggy Scroll Performance with Grid Lines Enabled

Hi, I was doing some google searches a month or 2 ago to figure out why my dopus was suddenly performing very slowly. I found some forum responses that apparently led nowhere and I gave up my search then.

Until it dawned on me, that perhaps the laggy scrolling was due to some opacity related stuff. My first thought was, grid lines. I went into the options, and sure enough, disabling grid lines completely improved scroll performance 10,000% (exaggeration of course, but the lag completely disappeared).

I then decided to re-enable grid lines and set the opacity to 100% for both. This worsened scroll performance significantly, which is strange because 100% opacity shouldn't be creating such a strain on my PC.

  • One thing is for sure, disabling grid lines definitely made the most significant improvement. The laggy scroll performance practically disappears.

  • Setting an opacity value to anything less than 100% results in severely laggy scroll performance.

  • Setting an opacity value to 100% results in moderate laggy scroll performance.

Suggested workaround - If a user chooses a 100% opacity value, then switch to a less performance intensive calculation to achieve better scroll performance.

Even better suggestion: Eliminate all performance problems by reprogramming this entirely, as it seems to be poorly implemented based on my very non-thorough deduction.

Hope you consider! :slight_smile:
Thanks!

Scrolling seems the same speed here with the grid lines on and off:

Here are the settings I think might be relevant, for comparison:


Are you using a background image or anything like that? Or any columns with background colors, or similar that might impact things?

Are you seeing this with 12.9, or an earlier version?

Do you have graphics drivers installed from the GPU manufacturer (NVidia, AMD, etc.)? The drivers that come built into Windows are extremely slow at some operations (in my experience with NVidia cards). Also note that Windows 10 tends to downgrade you to built-in drivers when it does its major updates every 6 months.

Off topic

"Also note that Windows 10 tends to downgrade you to built-in drivers when it does its major updates every 6 months"

It also insists on installing the ASUS smart mouse which sucks over my synaptics which is always a pain to re-install which is why my connection is set toe metered and I have chosen not to install the 1803 upgrade so far.

DO you have any suggestion that would help me out

Hopefully this video is helpful. :slight_smile:

1 Like

Many thanks for the excellent video! That helps understand what you're seeing and what to look for.

I'm finding that if I add a lot of extra columns to a full-screen (4K) window, and turn on both horizontal and vertical grid-lines, I see a slight decrease in scrolling speed, but nothing like as much as what you're seeing there. What I'm seeing with my config is along the lines of "doing more takes longer", but what you're showing in the video is beyond that into "something is making things ridiculously slow for no good reason".

I wonder if the problem is from some other settings that may not be obvious. e.g. I have relative size graphs displayed as separate columns instead of under the main size column, which I haven't tried yet. There could be lots of things like that, and it might be several things adding up instead of a single setting.

To save time, would it be possible for you to send us a backup of your config, so we can try with exactly the same thing?

If you're OK with doing that, you can make a config backup using Settings > Backup & Restore. The .ocb file it outputs is really a Zip archive if you rename the extension, and most of the config data is text/xml, if you want to look inside to see if there's anything you want to keep private. (e.g. Stored FTP passwords is the main one, and of course not something that will matter to reproducing the problem.) Please also send it via private message (or email to leo@gpsoft.com.au if preferred).

1 Like

@Leo, I have PM'd the requested OCB file to you. Hopefully it is helpful!

1 Like

Do you have smooth scrolling enabled in "Prefs / File Displays / Mouse"? (From your video, it seems to be the case.)

It might be unrelated to your problem, but in my experience it's a performance killer, especially when many files are selected and opacity is activated (on top of coloured columns).

This issue came up again today ( Laggy scrolling in Lister ) and I think we've got to the bottom of it now. It's probably what you were seeing as well.

We've made some code changes for the next beta (12.16.3) which fix the underlying problem.

In the meantime, if you turn off Preferences / File Display Modes / Details / Vertical for now, you should see a big improvement, but once the new version is out you should be able to turn it on without the big performance hit.