Launch DO9 with double-click not working in WinVista

I also have this issue, UAC enabled or disabled doesn't matter. Explorer Replacement Mode on or off doesn't matter either. I never installed Opus 8 on Vista. I don't think everyone is getting this though. Any others getting this issue?

I would try uninstalling Opus 9, then reinstal Opus 8 and uninstal Opus 8 (to make sure it removes anything that might be left over) then reinstal Opus 9, and then check if desktop double-click now works, before importing any previous configuration.

That should tell us whether it's something left over from Opus 8 or not.

I think part of the problem is everyone who forced Opus 8 to run on Vista made slightly different changes to the registry and/or compatibility settings so it's hard to know exactly what the state of their machines is and fixes for one may not apply to another.

It's possible this has nothing to do with the previous Opus 8 install, of course.

Oh, another thing to try: If you open Task Manager and add the Command Line column, is there a process with the command line "...\dopusrt.exe /dblclk"? If not then that's the problem.

I experience this as well, and I never installed Opus 8 on Vista.[/quote]
Recently, or during the betas? The function was broken in the early betas but has worked for a long time since.

If Quad is running dopus.exe as administrator (not recommended!) then it will almost certainly break desktop double-click because the small program (dopusrt.exe) which handles desktop double-click cannot send messages to dopus.exe to tell it to open, because non-admin processes are not allowed to send messages to admin processes.[/quote]

I do not remember seeing this issue in the Betas. However, most of my testing was on XP, so I might not have triggered it. I have never installed Opus 8 on Vista, so this can be eliminated as a possible root cause or trigger. I have seen this issue, but I just managed to work around this. It is related to UAC or a good reboot after installation, or both.

Everyone who has experience this issue, please try the following and report back your results:

NOTE: Always restart the PC from the arrow menu to the right of the Start Menu - Lock Workstation icon (or when prompted by the Opus installer). By default, the Start Menu - Power Button Icon only puts Vista to sleep (hibernate); it does not shut down the PC! This can be changed in advanced Power Profiles.[ol][li] Backup your Opus 9 configuration first of course.
[/li]
[li] Until otherwise noted, log into Vista 32-bit under an Administrator account with UAC enabled.
[/li]
[li] Uninstall Opus 9 completely from Vista 32-bit and reboot the PC.
[/li]
[li] Re-download and install the latest Opus 9 release.
[/li]
[li] In the Opus first-start wizard, choose personal configuration files. (I don't know if this is relevant one way or the other to the issue, but it is what I did to get my results).
[/li]
[li] In the Opus first-start wizard, make Opus the default handler for all things, except replacing Windows Explorer as the default handler for folders. (Again, I don't know if this is relevant one way or the other to this issue, but it is what I did to get my results).
[/li]
[li] Close the Opus Splash Screen.
[/li]
[li] At this time, do not restore any previous configuration (Opus 8 or Opus 9). Stick with the default out-of-box configuration. This eliminates upgraded Opus 8 settings or custom Opus File Types from the list of possible root causes or triggers for this issue.

NOTE: My Vista OS is pristine (no registry tweaking). Only hardware drivers and Opus 9 have ever been installed. So I can eliminate interactions with most other software (firewalls etc.) as possible root causes or triggering events.
[/li]
[li] Double-click the Desktop

ACTUAL RESULTS: Note your actual results.
[/li]
[li] Shutdown and restart the PC.
[/li]
[li] After the PC reboots, close any automatically opened Opus listers. (Curiously there were not any when I rebooted.)
[/li]
[li] Double-click the Desktop

ACTUAL RESULTS: Note your actual results.[/li][/ol]
Sometime yesterday I enabled UAC and another time I disabled it. If the above script doesn't work for you, as written, try disabling UAC before installing Opus, doing the script above, the re-enable UAC at the end. One way or the other I was able to get everything working correctly. But somewhere along the way I got different results and UAC seemed to be the key.

After I got my double-click working, I am able to import my saved Opus 9 configuration and it still works.

Those of you with the desktop double-click problem: If you haven't already, could you please try exiting and restarting Opus? (Use the tray icon to exit it.) If that doesn't work, could you try rebooting, when convenient?

I just installed a more recent version of Opus 9 and my desktop double-click stopped working, because I have not rebooted yet. Restarting Opus seemed to fix it in my case. It's possible the installer turns off the program that makes desktop double-click work (dopusrt.exe /dblclk) and it doesn't get turned back on until a restart.

Sorry if this doesn't help but I figured maybe some of you have installed a newer version but not yet rebooted like I just did.

[ The thread More of the same - Vista + DO9 issues moved into the same topic as this one so we've locked the other thread and will continue here to try to keep all the info in one place. ]

Quad, what you described in the other thread, about dopusrt.exe being blocked at startup and not being able to send messages to dopus.exe, sounds precisely like what will happen if one of dopusrt.exe and dopus.exe are running as administrator.

I know you uninstalled Opus and did a fresh install but it's possible Windows remembers the "administrator" state separately (I don't know to be honest). Could you check the properties for both dopusrt.exe and dopus.exe to make sure they're not set to run as administrator (or any other compatibility settings)?

Regarding the Opus 8 icon on your desktop, a few people over in this thread had problems with Windows caching the old Opus 8 icon. They solved it by using TweakUI to clear and rebuild their icon caches. Seems that Windows isn't noticing that the icon file has changed for some people.

@Leo I swear this must be the case. I installed the same Opus 9 release version on Vista about 4 times Yesterday and today. In all cases double-click didn't work. I tried enabling and disabling UAC after I had installed Opus. But today I got wise and disabled it when I installed Opus. All of a sudden, during one of the installs, it just "took". Ever since then, I cannot recreate the issue. (And you know how thorough I am at documenting steps to recreate issues.)

It seemed to correct on a pass through the script above were I installed Opus 9 with UAC disabled but only after the reboot at Step 10. (Before the reboot double-click still didn't work, after it it did work.) Now ever since then, I cannot uninstall Opus and re-enable UAC to get Vista to recreate the issue. That tells me the state must be remembered separately.

I just checked and Windows definitely does remember the "run as administrator" setting separately from the exe file. Try it for yourselves if you want:
[ol][li]Copy an exe into a random test directory.[/li]
[li]Set the copy to Run as Administrator via the Properties dialog.[/li]
[li]Delete the copy.[/li]
[li]Copy the original to the test directory again.[/li]
[li]Bring up properties on the second copy. You'll see it is set to Run as Administrator, even though the file it's a copy of is not.[/li][/ol]
Windows Vista must remember somewhere that "an exe with this path is set to run as administrator" even if the exe is subsequently deleted or replaced.

I think there's just a list in the registry.

Okay, on my PC right now, I do not have UAC enabled. I inspected both dopus.exe and dopusrt.exe, neither are set to run as Administrator in the File Properties dialog. I can double-click the desktop and open a new lister. And my best guess is that the fix is uninstall Opus, then run through my script above, With UAC disabled. Then re-enable UAC, after Opus is up and running.

It would be great if someone else could try that and report back if it works around this issue.

I don't understand - there should be no need to disable UAC. Just make sure that, if you had Opus set to run as administrator, you don't any more. UAC shouldn't really come into it.

Jon,

I think you missed how I'm a little different that the others here—I never installed Opus 8 on Vista, so I never applied any of the tweaks/hacks others did, to try to get Opus 8 to work on Vista. I only installed Opus 9 Betas that were Vista compatible, and the release version. Each time, I have meticulously cleaned the previous Opus 9 beta/release off of my PC before installing the next one. I never once have set Opus to run as an Administrator, and it is not set that way now. But despite all of this, I still encountered the same issue as everyone else—This morning (my time) I could not double-click the Desktop to open a new lister.

What seemed to fix the issue for me was to install Opus as I described above—with UAC disabled and ensuring a reboot after Opus 9 was installed. Otherwise, like the others here, double-click on Desktop did nada. Now having install Opus 9 in this way, I have re-enabled UAC and it Desktop double-click works flawlessly.

Never once have I told Opus to run anything as an Admin.

Don't worry Ken, I certainly know you're different to the others :slight_smile:

Maybe something killed the dopusrt.exe background process? If it ever happens again, check in Task Manager to see if dopusrt.exe is running (it should have a command line of /dblclk). If not - there's your problem. I really think the UAC thing is a coincidence.

I would if I could.

Currently, I'm in a state where I cannot even reproduce the issue, even after uninstalling Opus 9 from Vista and starting over. That is what currently has me baffled more than anything. Yesterday multiple installs couldn't clear it, and today multiple installs cannot recreate it. (And, yes, it's the same release download executable.)

This is why I asked others to try my script and note their results. Hopefully someone else narrows down exactly what works around the issue. I don't claim to know what does, I just know what I did.

Yeah I understand that. What I'm saying is, I think it was probably just one of those things. If it happens again, check Task Manager and maybe that will tell us something. Otherwise, move on :slight_smile:

I had the same prob until I installed in the default directory. Now everthing fine.

Just thought i'd mention what ive tried tonight. Complete, thorough uninstall, delete RegKeys, folders, the lot.

Reboot.

Turn UAC OFF

Reboot

Install fresh downloaded copy of DO9. Choose all the defaults, works perfectly. No UAC prompts, doubleclick on desktop works fine, etc, etc.

Reboot

Log in, DO9 starts up automatically, works perfectly.

Turn UAC back ON again.

Reboot

DO9 blocked at startup, dbl click desktop doesn't work, etc, etc. Get UAC prompt everytime I try to run it.

Oh and I still got the DO8 Icon, which Im not bothered about because it's a 3 second fix.

Haven't got time to faff about with more installs/uninstalls tonight but will post info if I do.

Although this thread is titled with the doubleclcik issue in mind, for me anyway it seems solve the UAC prompt message and everything else will be fine.

Cheers - Quad

Quad, did you bring up Properties on dopusrt.exe and dopus.exe to confirm they're not set to Run As Administrator or any other setting on the compatibility tab?

Just noting that I am about to re-install Vista, for reasons associated with a problem I am having with DOpusInstall.exe.

Just wanted everyone to know that I have not just ignored their suggestions, but I am now convinced there must be something amiss with my Vista build, and that could be causing any other problems I may be experiencing.

Thanks all for your suggestions. I'll be back. :confused:

Regards...

Bernard

My experience with getting a lister to appear when double-clicking the Vista desktop is that it doesn't work until I go to Preferences > Launching Opus > From the Destop. I check the "Disable" radio button, click "Apply", then check the "Open the Default Lister" button and click "Apply" again. Double-clicking now works for a time. At some stage it seems to stop working again; I haven't yet figured out what might be linked with this loss of the double-click function.