Layer style not working as I think it should

I've been reading Andy's excellent 'Other Manual' and liked his layer style for images. I've tried to create the same setup but am failing.
Both file displays show thumbnails, despite my setting shown below:




The other thing puzzling me is the tab name. The image display shows the name as 'Web Downloads' which is the name I gave to a different tab in my default lister. It only happens if that tab is selected when I switch to the Images Layout.
What am I doing wrong?
Any help would be greatly appreciated.
Thanks.

Hi Trevor,
About the thumbnails, I wonder if there could be a display mode override story happening with the default mode for your folder? (Which appears to be a library?)
In the folder, when you hit Folder Prefs (the button next to the Prefs button) then the Display tab, what does the "View As" pull-down say?
Or maybe you have turned on the mode that automatically decides how to display a folder based on its contents?
I think that's the one in Prefs / Folders / Folder Formats / click the Images format / Edit icon at the top / Options tab / content threshold, and is the Image box checked...?
Regarding the unrelated folder names, something like this happened to me a while ago. I forgot what I did. Maybe I deleted the style and started over.

Hi Andy, thanks for the reply. I unchecked the Images Content Type format as you suggested. However, both displays showed Details! :laughing:
I've solved it I think. I checked the Format Box and edited that to Thumbnails.

Thanks again.

Sadly, my optimism was misplaced. :frowning:
I still cannot achieve the style Andy uses for images. I have unchecked the Enable Folder Content Type Detection check box and used the settings shown above, but it refuses to show details in one display and thumbnails in the other. I either get details both sides or thumbnails.
Any suggestions on how I can resolve this would be appreciated. I can't think of any other preferences that could influence this behaviour.

If you click the Tabs button for the left and right parts of the style, is it defining any folder tabs for either side?

Folder tabs have their own formats which override the style's main format, so that may be what's going on.

If not, hover over (don't click) the format lock on the status bar and it should tell you where the format for the active file display is coming from.

Thanks for the reply Leo. I've checked the style and there are no tabs listed, just the close existing folders tab is checked.
When I hover over the padlock it says that the current format comes from the Default format.

How are you invoking the style?

From a toolbar button using "Prefs STYLE=Pics"

As an addendum, I cannot get NavLock to work either now. Accepting both displays as showing details at the moment, if I click on a sub folder in the left display the right remains at the top level and a message appears saying that the 2 folders are no longer in sync. I have verified that the correct vertical display (with the icon) is selected in Styles.
Interestingly, if I click on the button once it displays the Pictures folder in both displays in detail mode, but if I click it a second time, the righthand side shows thumbnails. However, NavLock doesn't work then either. :confused:

Hi Trevor,

I have an idea for you in #2, and a request in #1.

  1. I wonder if somehow Styles can get corrupted? I had a similar problem not long ago.
    Can you please paste /dopusdata/ListerStyles in the path bar,
    then open your Pics.ols file with Notepad, and paste the content of the file on this thread?
    That way maybe something will jump out. It would be nice to get to the bottom of this.

  2. Here is the content of my Pics file from /dopusdata/ListerStyles
    For now, I suggest you create a new style (say Pix), dump this text in the ols file, and see if it fixes it.
    Make sure to edit the two paths.

<?xml version="1.0" encoding="UTF-8"?>
<style hidden="no" order="7">
	<layout flags="0x107018200f" view_mode="details,thumbnails" />
	<folder1>
		<pathstring>C:\Users\owner\Desktop\TEMP\0 pix_temp</pathstring>
	</folder1>
	<folder2>
		<pathstring>C:\Users\owner\Desktop\TEMP\0 pix_temp</pathstring>
	</folder2>
</style>

Hi Andy,
here's the Pics style content you asked for:

<?xml version="1.0" encoding="UTF-8"?> lib://Pictures lib://Pictures

I'll have a go with your content and see what happens. I'll keep you posted.
Thanks again.

Hi Trevor,

Thank you. To me, it looks identical, except for one thing: your path is to a library.
Wondering if this would be a problem, Leo would know.
How about trying a path to a "hard folder" in your Pics style, just to see if we can isolate the problem?

It would appear that my problem is something to do with the fact that the folder is a library. I've just created a folder/sub folders in the root C:\ and changed the style to that and everything worked as it does for you, Andy. I went back and reverted to lib://Pictures and it stopped working again.
Perhaps that will help resolve the problem.
I really appreciate the help you and Leo have given here and in the past. Not only is Opus a superb program but the forums take a lot of beating too! :thumbsup:

PS Just seen your post Andy - great minds think alike (well, one great and mine)

Sorry, I didn't see this thread until just now. I tried the exact same thing last night, and also had both of the issues mentioned above of a) Folder Format changing and b) navigation lock behaving erratically. The way I solved these is as follows:

I followed the steps given in the manual to create the initial layout, and then tweaked it a bit to my liking (changed the width of the second folder pane and such). I have automatic content type detection checked because I find it often useful, so, to prevent that from changing my formats I then locked the folder format for this layout. I then saved the whole layout. Now when I want to switch to this style, rather than changing the style I switch to the Pictures Layout I have saved. I have found that this also solves the issue I had with the Navigation Lock not working correctly. Before, what would happen was that the first time I swicthed folders, I would get a warning from Navigation Lock that I was out of sync, and I would have to go back to the previous folder and resync. From then on things would work, but this drill got old rather quickly...

Hope this helps someone...

Good catch!

Jon has written a fix for that which will be part of Opus 10.0.3.1-beta, which we aim to release later this week.

Thanks for the update, Leo. :slight_smile:
That's a relief, I thought it was me.
Pirx thanks for the suggestion.

No, I think you are it. :slight_smile:

Hey, really glad you got it solved.

Wishing you a good week.