License Certificate not accepted


I'm using the latest DOpus 12 64-bit on Windows 10 Pro 64-bit. This is a fresh install of Windows 10 Pro on a formatted SSD (I came from Windows 7 Pro a few days ago).

I have never had a problem entering my license certificate until I went to Windows 10.

I can load the license certificate and it will tell me it's valid. Everything will be fine for a day, or only a few hours, and then it will pop up the License Manager and act as if I'm not licensed!

This has happened at least three times over the past two days. Sometimes I can enter the certificate again and it will accept it, but other times it will pop up a window saying that "Access is Denied and that I must have Administrator privileges in order to install a certificate".

I only have one account on this computer that I log into and I am the Administrator.

What's going on?

Thank you,


Are you using Avira antivirus?

Others may cause the same problem, but that's the only one doing it that we're aware of.

Hi Leo,

Right now, the only protection on this system is what comes with Windows 10 Pro. I have not installed my security software, yet.

The access denied error means that something is preventing your Windows account from writing the certificate data.

If you go to C:\ProgramData\GPSoftware\Directory Opus and delete dopus.cert then try it again, that may resolve things.

On a normal Windows 10 setup, you should see a UAC prompt when installing the certificate. Does that happen OK?

If it still isn't working, making a Process Monitor log of what happens when you install the certificate may reveal what's going wrong. Please zip and send the log (or a cloud storage link to it) via email or private message if you make one.

Hi Leo,

I have this path on my system and there isn't any dopus.cert in it (but, that could be because DOpus 12 has reverted back to a trial version after dumping my license several times):

C:\ProgramData\GPSoftware\Directory Opus\Global Data

There is a globaldata.omd file. There is nothing else in that directory structure right now.

I tried to install the certificate by double-clicking on it and I get the popup saying access is denied and I need Administrator priviledges.

There is only one account on this Windows 10 install and I am the Administrator.

In the past, if I reboot the computer and then try to install the certificate, it won't give me that error and it will install the certificate.

I'll reboot now and report back...

OK, a fresh reboot and I still get the Access Denied, I need to be an Administrator to install a certificate!

I have made the requested log file and sent it via PM.

Thank you!

Looking at the logs, something is blocking globaldata.omd from being replaced in C:\ProgramData\GPSoftware\Directory Opus\Global Data.

Are you able to delete that file manually? If so, please try installing the certificate after deleting it.

Hi Leo,

OK, before I read your latest response, I rebooted a few more times and tried to install the certificate and it kept saying I needed administrator access.

Just now, I reinstalled DOpus 12 by right-clicking on the installer and said Run as Administrator. It installed and I rebooted.

I successfully installed the certificate and when I look at the ProgramData dir, I see this structure inside the DOpus dir now:

Buttons (dir)
Global Data (dir)
Icons (dir)

The globaldata.omd file is still there.

When I installed the certificate Windows did NOT pop up the UAC Yes/No requestor. I have the setting for UAC at its Default setting.

I am sending you another log file of the successful certificate install via PM. Maybe a comparison of the two will lead you to a solution?

In the past, DOpus reverted back to the trial mode and popped up the License Manager on its own asking me to install a certificate and telling me I had X days left on my trial.


Did you try deleting the globaldata.omd file?

Should I do that now after the successful certificate install?

No, no need. I was just wondering if you did that before installing the certificate the time it worked.

If you didn't then it sounds like the folder permissions may have been wrong, which the installer attempts to correct if it can.

Please post here again if you run into problems again, and we can suggest some things to investigate with that in mind. Maybe something is modifying the permissions on the folder.

OK, if it pops up the License Manager again, I will go in and delete the globaldata.omd file and then reinstall the certificate.

Does it concern you that I'm not getting a UAC warning when installing the certificate? I do get one when I install DOpus.

Thanks Leo!

No, don't worry about that. After a further look into things, the UAC prompt only happens in some situations and a lack of one isn't an issue on its own. I was mistaken when I said it should always appear.

Thanks for the logs and help diagnosing things. We've made a few changes that might help based on them, too.

So far, so good with the license holding.

Thank you for your help, Leo.

1 Like