GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Lister Theme not applied (dop 12.6)


#1

Hello,
i am trying to apply a lister theme, but it seems none of those i downloaded are actually applied.

I click on "import", select the file, click apply. Dopus restarts...and it looks like before.

Why is that? Maybe not all themes work with dop 12.6? Or am i doing something wrong?

Thanks :slight_smile:


#2

Which theme are you having problems with?


#3

Well..both with "Linux Mint Cinnamon" and "Simple Dark Theme".


#4

Here's what happens for me with Simple Dark Theme.

Are we both doing the same thing?


#5

Yes we are...The only difference i see is that i'm on Windows 10 (home). When Dopus reload itself, it gets back as if i didn't select any theme.

Maybe i have some wrong settings somewhere that are causing Dopus to ignore the theme i select? I don't know


#6

If you:

...do those changes stick?


#7

No. I can see them working as soon as i click "apply", but when i restart Dopus every setting is like the same.

Another thing (don't know if it might help) to consider, is that i installed Dopus 12 on this new machine (windows 10) and restored a backup i had of Dopus 10.

Can that have anything to do with this behaviour?


#8

Importing an old config shouldn't be a problem.

Something to try:

  • Type /dopusdata/ConfigFiles into the location field.
  • Create a backup copy of `prefs.oxc'
  • Open the main copy (not the backup) in a text editor. Notepad will do.
  • See if you can add a space or a return to the file and save it, close it, then re-open it. Does it save successfully and remain there when re-opened?
  • Restore the backup of the file to put things back to normal.

If saving fails, it's likely the file permissions on your profile folder have been messed up. (It will probably prevent some other programs from saving their settings as well.)


#9

Yup, that's the issue. But the error message i get (even after i close Dopus with file -> exit and kill the remaing dopus process in task manager) is "file is in use by another process".

Perhaps i should change configuration mode to "Shared"?


#10

You might be able to find out which process has the file locked using Process Explorer, Find > Find Handle or DLL, then type the file name in and click Search, like this:


#11

Process explorer doesn't find anything, and i still get the same error when trying to edit the file (even with notepad as administrator).

:disappointed_relieved:


#12

Try running Process Explorer as admin, if you didn't already. Sometimes it can see more then.

If it still can't see anything locking the file, I'd start to suspect antivirus might be causing changes to the file to fail for some reason, although it is very strange that you get a file-in-use error and not an access-denied error.


#13

Now it does detect a process, but it's a generic "system"


#14

System may indicate something on another computer has locked the file via a network share.

This has some suggestions on how to deal with that, as well as several other possible causes & solutions (ignore that it says Windows 2008 R2; that detail doesn't matter):


#15

hi Leo,
The Directory Opus 12 Light I purchased from Humble Bundle seems to have failed.
Would like help me to restore it?
I send a mail to support@gpsoft.com.au
I wish you can open it.
Best wishes!


#16

Tried that as well...so far no luck. Damn this is driving me crazy!


#17

SOLVED!

  • Backed up my configuration
  • Uninstalled Dopus
  • Resintalled Dopus
  • Restored my configuration

Everything works now!

Thanks for all the support you gave me Leo, sorry i didn't think about doing this earlier :slight_smile:


#18

Please start a new thread for help on that. It's very off-topic in this thread about a totally different issue.

Please also post some details in the new thread about how it fails. e.g. Does it start at all? Do any windows open? Does it crash or freeze? Are there any error messages?


#19

I have a similar problem but in 12.7
I've tried several themes VS Dark, Visual Studio 2017 and the cinammon theme. None of those themes apply.
I download the .dlt to the themes folder of the program and it always says to me that there are no themes and sends me to the web to download one.
I'm on W10 x64, and I've followed more or less your instructions in here.
-> Tried to change a colour and see if it sticks, and it does.
-> The edit of prefs.oxc also works fine. It stays modified.
-> Also tried the Process Explorer stuff and even in admin moden nothing turned up.

Tried double click on the theme and nothing. also right click and open with Directory opus and nothing....
I don't know what else to do.

P.S. since this is a problem with 12.7, should I make a new post?
Thanks in advance


#20

Themes have to be loaded via Settings > Lister Themes. See the video in the 4th post (above) for a quick example.