GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Lister won't open on startup (portable mode)


#1

I'm using DOpus in portable mode. I've set in the preferences to open the last used lister upon startup. So when I run the exe from the USB, nothing happens. Then I run the exe file again, and now the lister opens. it always takes twice to open the lister. How come? What is the first one doing?


#2

I have no experience wth the portable version, but if it's anything like the regular version, what the first one is doing is starting the Opus process running in the background.


#3

With the regular version it can depend how it's run (which arguments are passed etc.) but stuff configured to open on startup will open by default.

I've not had a chance to see what happens with the USB version, though. Will try and take a look when I get a moment.


#4

Oh, right. I forgot I have Don't open any Lsters selected in Preferences -> Launching Opus -> Startup.


#5

My Startup options is set to open the last used lister, but like I said, it doesn't work. I always have to run the dopus.exe file twice for a lister to open.


#6

Do you actually have a Lister open when you quit Opus previously?


#7

Well, no. I have to close to program at some point.

So, based on what you said above, I changed the startup setting to open a saved lister. That one works. It opens the lister when the program is run the first time.

So my question now is, how can I have the last open lister open upon running the program the first time? I mean, I have to close the program at some point! It's not like I can quit opus without closing any of the programs, right?


#8

Closing Opus's windows doesn't exit the program (by default at least).

See How to Exit Directory Opus for a quick summary/explanation.


#9

[quote="leo"]Closing Opus's windows doesn't exit the program (by default at least).

See How to Exit Directory Opus for a quick summary/explanation.[/quote]
Geez, I missed this. THanks! I have to try it this way.