Location of "My Documents" folder

On opening DO previously the "My Documents" folder appeared near the top of the folder tree directly under Libraries, Documents, along with Public Documents. Suddenly it no longer appears there and Libraries only has the Public Documents folder and not the My Documents folder. Now I have to go down the whole list of folders starting with the "C drive" then to Users, then to the folder with my name and only then to the My Documents folder. When I used Windows Explorer to investigate this I found the same situation, except that I could relocate My Documents back up to the Documents folder under Libraries using the right click option of Include in Library. However DO will not let me do that, responding with the statement that Documents already exists, although I am trying to relocate My Documents, not Documents. Is there any way to correct this problem? Thank you.

Which folders does Windows Explorer show in tree below Libraries / Documents?

If you right-click the library (in Opus or Explorer; shouldn't matter which) and choose Properties, which folders are listed as being part of it?

Library member folders should match between what you see between Explorer and Opus... though definitely verify what Leo asked you.

Besides that... though I think it's enabled by default, perhaps this option is DISABLED in your prefs... leading you to THINK that the 'My Documents' contents are not included under the Documents library?

And even if not, probably worth posting some screenshots of what looks wrong between Explorer and Opus.