GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Lock-ups with TortoiseSVN 1.6.3-1.6.6 on XP -- Fix available


#1

[Admin note: See this post on page 2 for a version of TortoiseSVN which should resolve the problem until the TortoiseSVN 1.6.7 release. Just adding this info to the root post so it's easy to find.]

Greetings,

I have the latest version of Opus 9, and recently updated Tortoise from 1.6.2 to 1.6.6. Later that day, I started having problems with Opus. I can't absolutely swear that Tortoise caused it, but it's all I remember doing between working fine and having problems.

Maybe once out of 10 tries, when I open Opus, it brings up most of the window, but then locks up, and I have to end task. During that time, Windows (XP Pro) file manager still works fine. When Opus does open, everything works fine, including Tortoise.

Has anyone else reported problems after loading the latest version of Tortoise? If I had a copy of my old 1.6.2 Tortoise, I'd install it to see if the problem went away, but I can't seem to find one.

Thanks,
Rusty


Dopus halts for unknown reasons (Edit: Tortoise 1.6.6)
Opus 9.5 Performance Issues
#2

Try the steps in the FAQ about crashes (etc.) when opening specific folders. (Or the related FAQ about crashes when right-clicking files if it's happening then.)

FWIW, I'm using Tortoise 1.6.6 without any problems.


#3

Thanks for the comments. It's good to know that the latest version of Tortoise can work for someone.

The only thing I saw in the FAQ that might relate is crashes when opening a specific folder. I typically use a link that does open a specific folder, but had already tried other links to different folders yesterday.

For lack of anything else to try, I reverted back to my image backup from Thursday, which still had v1.6.2 of Tortoise. So far, all is well again. I'll give it a couple days, then try v1.6.6 again (immediately after an image backup), and see if the problem returns, though if I was smart, I'd just leave well enough alone.

Cheers,
Rusty


#4

Do you have anymore news on 1.6.6?

I experience the same problems


#5

I haven't tried it again, since 1.6.2 Tortoise is still working fine. I had some other issues that ultimately weren't caused by Opus, and asked Greg about the Tortoise issue as well. He said he wasn't aware of any problems, and that he uses Tortoise as well.

I saw a note on the Tortoise site that said some people had problems with the initial install, and that uninstalling, and reinstalling Tortoise 1.6.6 a second time would take care of it. I'll try that next time I load 1.6.6. The other option is to just wait until there's a 1.6.7 and try that instead.

Rusty


#6

Did Tortoise 1.6.5 work okay for you?

1.6.6 still works fine for me (and for GPSoftware, from speaking to them) so it'd help to know exactly which version of Tortoise introduced the problem so that we can look at what changed and try to understand what's going wrong.


#7

I suppose so. Mostly I upgrade Tortoise as soon as I get the upgrade message, so around Oct 22nd. The problems are something of the near past.

But I cannot pinpoint the problem exactly, since many things changed after my fresh reinstall. Would you recommend a uninstall of 1.6.6 and install of 1.6.5?


#8

Yes, please install 1.6.5 and see if the problem goes away. If it does, go back to 1.6.6 to confirm the problem comes back and it wasn't just the install going wrong.

(I've noticed sometimes I have to install Tortoise twice for it to update properly, so maybe it doesn't always copy all of the new files when installed?)


#9

[quote="leo"]

(I've noticed sometimes I have to install Tortoise twice for it to update properly, so maybe it doesn't always copy all of the new files when installed?)[/quote]

Interesting. I noticed this in the Tortoise help info, and planned to try it twice if I have problems in the future.

Thanks,
Rusty


#10

I just changed to 1.6.5 and will give it a try for a while.
I'll let you know if the problems re-occur.


#11

I went back to 1.6.3 and 1.5.10, but the problem remains


#12

It sounds like your problem probably isn't related to Tortoise then. Try to think about what else changed when you believe the problem started.

If you like, you can create a minidump of Opus when it is in this hung state, and send it to us for analysis. Instructions for doing this are here.


#13

jon, I followed your link and it points at a vista situation.
userdump8.1 for XP will probably do the same.
When do I make a dump? At the moment DO halts or just now?
And where do I send it to?


#14

When it's hung. You can send it to me directly - jon at gpsoft.com.au.


#15

After a couple weeks of working fine with Tortoise 1.6.2, I installed the latest 1.6.6 again, and the lockups returned in just a few minutes. I tried uninstalling and reinstalling Tortoise 1.6.6 as suggested, and the lockups remain as before.

I'm running XP, so the dump link doesn't work for me, and I installed userdump8.1, but can't make it do anything. No matter what I tell it to save, it does nothing.

I did notice that XP's error reporting saves the dump files temporarily, to allow you to send them to MS, and I was able to save those files, and will be sending you an email Jon.

I've now removed Tortoise 1.6.6, and installed 1.6.3. As I mentioned, I couldn't find a copy of 1.6.2, so I'm really hoping 1.6.3 works. If not, I have to reinstall my last image backup to get back to 1.6.2.

Cheers,
Rusty


#16

Sadly, I still get Opus lockups with Tortoise 1.6.3, so I just reloaded my image backup to get 1.6.2 back. Unless something shows up in the dump file that I sent to Jon, I'll either have to stick to 1.6.2 of Tortoise, or drop Opus and go back to Windows Explorer.

Rusty


#17

Which actions do you perform using Tortoise? Maybe you use part of it which triggers the problem that those of us using Tortoise without the problem don't use?

Do you know what kind of SVN server Tortoise is talking to? Is it an actual SVN server or are you using SVN in the mode that just requires a network share? (If it's a network share, is it a Windows share or something accessed via SSH and plink or similar?)


#18

Try with Opus 9.5.0.2 as well if you've not installed it yet. I think Jon mentioned making a change which might help, based on the dump file he received, but it's hard to know for sure as the cause of the lock-up is still a mystery.


#19

I'll give the beta version a try when I get to a point that I can make a new image backup, and dedicate an hour or so to the process.

As for what I'm doing when it locks up, all I'm doing is clicking on the icon to open Opus, as described in the first post.

I'm not actively using Tortoise at the time of the lockup of course, though I supposed it's always active in some form. I'm really software challenged, so all I've figured out how to do with Tortoise is "checkout" and "update". I only have two real SVN sites that I need to get code from, and that's all I do with Tortoise.

Thanks,
Rusty


#20

Which folders do you have Opus set to show when you start it? Are they folders with SVN contents in? Are they network or local folders?

Are the SVN sites you're using public ones? If so can you provide the details of them?