GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Loss of Labels when moving mp3 files


#1

I’m labeling my mp3 collection and I’ve noticed that some, but not all, of them lose their labels when I move the files. I’m certain I’ve applied the labels correctly, but they disappear. Which brings up two questions…

  1. Has anybody else encountered this?
  2. Is there something I can do (other than not moving files) that will prevent the loss of labels?

Thanks in advance.


#2

Are these two settings on or off?

Preferences / Favorites and Recent / Labels:

  • Enable label storage in the file system (NTFS volumes only)
  • Automatically store labels in the file system if possible

#3

Enable label storage in the file system is enabled, the other wasn’t. I’ll enable the other.

Thanks.


#4

That’ll be it.

You might also want to look in Preferences / Favorites and Recent / Label Assignments and clear out the labels stored in Preferences for the old file paths, to avoid confusion.


#5

I went to Settings > Preferences > Favorites and Recent > Label Assignments and deleted the paths and labels. When I go back to check those files, they have no labels. What exactly did you mean by “clear out the labels stored in Preferences for the old file paths?” Please give specific menu items.


#6

That was what I meant.

Now when you add labels they should be added to the files themselves, not stored in Preferences.

One extra thing you may need to do is turn on the option to Copy Metadata under Preferences / File Operations / Copy Attributes.

(Note that copying metadata will slightly reduce copy speed, especially when copying lots of small files.)