GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Lost Drop/Paste

In a Lister with two windows sometime I cant drag and drop to copy/move files from one Folder to the other in the lister.
I can move copy/from one Folder to the desktop and then from the desktop to the oteher folder.
The right-mouse-popup-menu with cut/copy and then Paste also doesnt work, the paste is grayed out.
If I close the Window and open a new lister then it works for a while. But after some changing the folders or copy/paste it stops working.
Cut/Copy/Paste with Explorer works allways.

I have deinstalled DOpus, and maked a new install with defaut settings. The same.

I have made a new WindowsXP installation and .... the same.

I'm using DOpus with WindowsXP Pro SP2.

I think it only happens after opening a network folder and trying to copy/cut/paste.

Some times after a copy/paste DOpus doesnt respond any more and stops working.

I have tried the CopyPaste.reg here from the forum but it doesnt helps.

Any Idea ?!?!

Are you running any programs which monitor or automatically modify the clipboard?

no, there are no programs running monitoring the clipboard.

Just made a system scan with avast, antivir, spybotsd, ewido. Nothing found.

There is one thing I forgot:
If I loose Paste then the popup-menu has no windows entries (Winrar, beyondcompare, Ultraedit...

If I close and reopen the liste I can paste and the popupmenu is ok.

Tried with shift - does not help.

My bet is that one of the things which adds items to the context menu is going wrong inside of Opus and that's breaking context menus for the lister.

Not sure how best to track down where the problem is. The FAQ on context menu crashes has info on how to get a list of all the context menu handlers which are involved each time you right-click (which can include ones you don't see in the menu since they may still be asked if they want to add an item). It might be the last one listed before things break which is causing the problem, but that isn't guaranteed.

You may find the problem goes away if you remove all 3rd party context menu items except those you really want, as explained in here. It's be good to know what was causing the problem, though, so that a fix or workaround could be made.

So I have made many tests.

Checked the Extensions using ContextMenuDbg in the registry.
Disabled the extensions using IgnoreContextHandlers in the registry.

But still it doesnt help.
But then I notized:
If I double-Click on a zip-folder it is openend in the lister so i can see the contents.
But I cannot copy/move the contents to the other lister.
But I can copy/move to the explorer.
Going up one level to the folder containing the zip I cannot use copy/move any more.

My settings are: (free translation from german)

  • Activate DOpus for Zip files: enabled
  • DOpus as standard-handler for zip-files: disabled
  • Show ZIP-Files in Folder-structure: disabled

If I disable the first setting a doubleclick opens the uzip in a explorer window. From there I can use copy/move.

And my problems are gone !!!!!!

Are you able to reproduce this ?bug?

I can't reproduce it here.

Does it happen with all zips? Might be worth a try creating a small zip with Opus to see if still happens with that.

I have crated a new zip file, very small. Same Problem.
I have reduced the problem:

I Have one DOpus Window with one Folder, Drive C:
On Drive C the is a file
I move the file in the folder pressing the left mousebutton and the Strg-Key so I can copy the file. Works.
I make a Doubleclick on the file to open it in DOpus window.
I Press Backspace to go back to C:
I try to copy with Strg+Mousemove - not allowed.

The whole time the debugging with ContextMenuDbg is active, but no window opens to show anything because I have all disabled with IgnoreContextHandlers.

If I use the richt-click-menu "Open with....compressed folders" the zip file is opened in the window like using doubleclick. But after Backspace to C: all is ok and I can copy !

I tried following these steps but it seems fine on my machine. Can you take a look at the video I made (300k Flash animation) and see if I did anything wrong?

Which mode do you have Opus in? (Details/List/Power?)

Helli nudel,
many thans for aour help but I think I have solved the problem.

I have made another new fresh install of windows.
Then step for step I installed all my software and tested if the error occurs.

I found that a driver of PowerISO was not correctly installed.

Many thanks again,

Ah okay, thanks for letting us know what it was.

Was this an unusual situation or do you think it would be worth adding to FAQ about other programs which may cause problems in Opus, in case it affects other people? (If it's worth adding, please provide some quick instructions on how to fix it.)

I'm having an excatly same issue. I do not have PowerISO installed. I loose drag and drop copy/paste after moving up or down directories, using up arrows on the lister or using bread crombs path links on the lister title bar. As soon as I move up or down, the drag/drop is gone. I can only bring it back by restarting the app.

BTW, I installed DO to two other machines that I have and it works just fine on those....