GP SoftwareTwitter
Opus FAQsManualCommandsObjects

McAfee Total Protection Context Menu Missing


#1

Hi,

I just installed the latest version of McAfee Total Protection and the two context menu items, “Scan” and “Shred”, are missing in DOpus 12.7. When in File Explorer, they appear no problem when right-click.

This is the first time I’ve experienced Antivirus context menus missing (I’ve used several other such software in the past), so do you think this is something fixed via DOpus or is it McAfee?

Thanks!


#2

Do they appear in anything other than Explorer, or just in Explorer?


#3

Just Explorer.


#4

Then McAfee are choosing to hide their context menu from everything else, for some reason. You would have to ask them why. (There might be a good reason, but it seems pretty strange.)


#5

But the same was true when, for example, I was just using Webroot; its context menu to do a file scan showed up only in explorer (i.e., it didn’t integrate menu-wise with any of my other apps; just Explorer).

Yes, strange and I’ll ask on their forum to see if I get an answer.

Thanks!


#6

You could do a test by copying Notepad.exe to explorer.exe (in another folder; don’t overwrite the real Explorer!) and see if the menus appear in its File > Open dialog. If they do, then they’re definitely doing it on purpose.


#7

I contacted their support and, ahhh, the beauty of outsourcing to those who do not understand. :wink: Believe or not, he directed me to turning off the firewall. :confounded:

Tried another agent and not much different, so I posted a question in the forum; let’s see if I get any responses.

Unfortunately, I think it must be McAfee itself doing some sort of protection on my system because believe or not, I could not copy notepad.exe and run it! I even tried Wordpad. They would only run under their real names. Must be something to do with Windows apps because I tried it with another an text editor and it was not a problem; however, I didn’t see the McAfee context menus there, either.


#8

There’s another virus checker that does this as well (I forget which).


#9

Ok, I have an interesting update: I just downloaded another Explorer replacement, installed it, and the McAfee context menus appear. So this definitely confirms that McAfee is not limiting it to just Explorer.

There’s a free trial for McAfee Total Protection, can you try to see if you can replicate?

Thanks.


#10

If they don’t appear in Notepad then it can’t be something that Opus is doing. I think you’ll need to ask them what the criteria are for when/where their menu items appear.

If their tool can be run via a command line then you could also add a menu item in Opus which does the same thing, to replace the missing menu.


#11

I wasn’t able to do the Notepad test because McAfee was “protecting me from myself” and didn’t allow Windows .exe files to be renamed and run under that new name.

Yesterday I installed a trial version of another File Explorer replacement app and the McAfee context menu showed up when I used that app.

Today, I installed and tested two other apps and the McAfee context menus also show up when I use those apps.

So it’s not McAfee. I would recommend that you download their free trial and see what results you get.

In the meantime, I will look at manually adding the menu items once I confirm the command-line syntax.

Thanks!


#12

Antivirus is a pain to trial as it’d mean uninstalling our existing antivirus. Maybe we can look at it using a virtual machine.

Before that, though, a couple of quick things:

  • Does it appear if you hold shift while right-clicking?
  • Is Preferences / Miscellaneous / Windows Integration / Hide Windows items on file context menus on or off?

#13

Yeah, I understand.

The Hide option is off and, no, shift-right-clicking does not have an effect.

However, that reminds me of something interesting during my tests of the other apps: In one of them, right-clicking did not show the McAfee context menus…but that app had a “Show 64-bit context menu” context menu option and when I clicked on it, the context menu was re-displayed and the McAfee context menu items were present.

I don’t exactly know what that means, but I thought it was interesting at the very least. It was the only one app that behaved this way.


#14

That just means that other file manager is still stuck in the 32-bit era and needs to use a kludge, running a separate 64 bit exe someone else wrote for them which displays the context menu for a file, to get the same 64 bit handlers/menus which Explorer and Opus and other 64 bit apps will show.

It implies that McAfee have not installed a 32 bit shell extension, so their menu won’t appear in 32 bit processes, but that’s fairly common. (Some programs install both 32 and 64 bit components so their menus work everywhere, but many don’t bother these days.)

Unless you are running 32 bit Opus on a 64 bit system (presumably via a portable USB export, and choosing the 32-bit-only option to save space), it shouldn’t affect Opus. But if you are doing that then it would explain it.


#15

Re the notepad test, renaming notepad is only needed to test if the menus come back if the process has a certain name.

If the menus are not there with the normal notepad.exe name then that tells us the issue is in the McAfee shell extension. From what you said above, that seems to be the case?

Renaming notepad would just be used to test the theory about which criteria McAfee are using to display their menu, if the menu is missing from notepad under normal circumstances.


#16

First, thanks for that detailed explanation about that 64-bit context menu option. It’s good to finally understand now.

I’m using a Surface Book, so I’m definitely using DOpus x64.

Initially, I thought your Notepad test was a bit weird because what I thought you meant would happen would be that when “File > Open” is selected, because it is notepad.exe running as “explorer.exe,” that the context menus would appear somewhere in the dialog window. That test as we know now could not be done so my silly understanding is irrelevant now. :wink:

However, after reading your post above about the menus still showing up in the normal notepad.exe, that’s when I realized I definitely misunderstood something! So, I ran Notepad, did “File > Open”, and–hello! :slight_smile:–right-clicked on a file in the dialog window and the McAfee context menus do appear.


#17

Have you been able test this in a VM yet to see if you get the same results?

It’s a pain in the butt to have to open File Explorer when I want to scan on-demand. By the way, even just right-clicking on a file on the desktop shows the McAfee context menus.

Also, I did contact support and asked for a command-line syntax to Scan and Shred and they said there were none, so that rules out manually adding the context menus to DOpus.

Thanks!


#18

We looked in a VM and we are definitely asking their context menu DLL if it wants to add any menu items, but it is not adding any when asked, for some reason. Why is difficult to tell as we don’t have their source code.


#19

Ok, thanks.

What’s also interesting is that it is this specific McAfee product (Total Protection) because on my work laptop I have the McAfee Enterprise Antivirus software and after installing DOpus on that machine, the McAfee context menu option appears. There obviously must be something different in how they implemented it in Total Protection.


#20

This morning I was about to do some testing when I noticed that the menu options were appearing when I right-clicked. Naturally, I was shocked and I noticed the file I right-clicked on was a shortcut file.

So I then went to a regular file, right-clicked, and no McAfee context menu options. Then I created a shortcut of that file, right-clicked on the shortcut and, yep, the menu options were there! This is now even more strange now that it works (only) for shortcut files. (Naturally, I’ve tested on numerous file types and shortcuts are the only one for which it works.)