Memory Leak when mass-moving files?

Hi,
I've had to stop using Directory Opus in the last few days for the process of moving huge chunks of files around on my hard drives as it some how is killing my Internet connection.
According to the Newsleecher nntp client that is also running, it has something to do with no buffer space being available (I think the error that NL reported was 10055, but I doubt if this means much wrt Dopus).

I have a machine that has several TBytes of HD attached and I'm having a bit of a "Spring Clean" and a reorganise of the data stored on the disks. This has meant large drag-and-drop operations of quite a few 100GB+ file moves.

I've noticed no real gradual increase in memory as the procedure continues, but, as I said above, at some point it appears that the "buffer space" is depleted and my Internet connection is lost.
The file move always seems to complete successfully, but this mythical buffer space is apparently not released by Dopus.
I've tried looking to see where the problem is - file handles, etc, but do not really know where to look, or what to look for.
All I know is, if I close Dopus, everything returns to "Normal" and magically my connection is restored.

Two other things to mention-

  1. I connect through a router via ethernet, and the loss of connection appears to be something to do with the failure of my ethernet connection.
  2. I am moving stuff off a USB connected drive sometimes and I wondered if this would have any effect?

The only real common things in all of this are that a mass-move of files using Dopus seems to suck some resource dry thus killing off my network connections and NL, and that everything starts working again after I close Dopus.
If I use Windows Explorer to move files. No problem.

Oh, one thing I have just remembered, when using Dopus for moves, processor usage hits the 100% mark and stays there throughout the process. When using explorer, it hovers around the 40% mark.
Something is just not right.

TIA,
Sue.

Have you got an AntiVirus program running which is checking files as they are moved/created/copied?

Hi, I can see where you might be going - AVG 7.1 Pro

The only thing is, why do the resources vanish under Dopus transfers and not under Windows Explorer?

[quote="SusiBiker"]Hi, I can see where you might be going - AVG 7.1 Pro

The only thing is, why do the resources vanish under Dopus transfers and not under Windows Explorer?[/quote]

I've got no idea. The only reason I mentioned Antivirus is that it's often helpful to identify other software which could be impacting on the problems - and in your case antivirus was the obvious candidate.

Have you tried the same sort of copies with AVG disabled?

Try turning off the movie plugin. The problem may be caused by Opus asking video codecs to get information from the copied files and the codecs going wrong.

Theoretically Antivirus stuff could behave differently for Opus and Explorer, since they do copy files in slightly different ways, but it would be worrying (in terms of the anti-virus doing something very silly) if that were the trigger.