GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Memory Usage Goes sky High (video codec?)


#6

Haven't forgotten. It hasn't done it again. I tried playing videos and such but it's being persnickety.

That's good to know MrC. That's pretty much where it goes eventually both vmmap and dopus have both shown usage of 14-15 gigs which of course slows the computer to a crawl and causes apps I'm running to freeze and such.


#7

Ok it finally does it again. So in one screenshot you will see dopus using up a ton of memory. I killed that process. I then launched vmmap and told it to launch dopus. Immediately it started to climb. I sat and watched it and when it got to over a gig I took the snapshot. You can see that there is a difference of like 200 megs. That's how fast it climbs. By the time I snapped the shot and opened up all the windows and arranged them it was already 200 megs more or so.

Once I kill vmmap dopus remains and seems to be ok for a bit. Screenshot should show my other processes in case something is interfering and causing it but I dunno.

[Huge screenshots removed as they turned out not to be useful and made the thread difficult to read/scroll.]


#8

The VMMap screenshot shows Opus using about 20MB of RAM, and VMMap itself (not Opus) using over 1GB RAM.

VMMap will use a lot of memory if there are a lot of memory allocations/deallocations going on in the process it is tracking, since it keeps a record in memory each time one happens.

VMMap using a lot of RAM to track events does not mean that it or Opus is leaking memory, though (and Opus doesn't seem to be leaking in the screenshot with VMMap, since it is only using 20MB). It doesn't tell us what was happening with the previous Opus instance that was using lots of memory (the other screenshot), unfortunately.


#9

Understood. In which case I do not know how to debug this. Vmmap will use all available memory before long and have to be shut down before dopus exhibits that behavior again. Perhaps I'll get lucky.


#10

One question. If VMMap is using alot of memory if there are a lot of memory allocataions/deallocations going on then should it be growing while dopus is idle? What is dopus doing that causes so many allocations and deallocations when it's just open and idle? Currently vmmap is 4.4 gigs and growing. dopus is still at 25megs.


#11

Ok think I found a way to monitor it. If I just launch it it'll go crazy like you saw but if I kill vmmap and re-run and simply tell it to monitor dopus then in idle I don't see the crazy memory growth so I'll leave it now and start messing with dopus to see if I can duplicate the behavior.


#12

Hmm. I left it monitoring dopus and it finally did it again, however, I couldn't trace it when I did it this way.However using it to launch Dopus just seems to result in vmmap using a ton of memory until I have to shut it down. Any other ideas? Maybe a debug mode for Dopus?


#13

As MrC explained above, VMMap is no good for long-term monitoring because it iself uses up a lot of memory if left monitoring another program.

I suggest you use ShellExView to disable all non-Microsoft and non-Opus shell extensions as it is likely to be one of them if the problem doesn't seem to be caused by something you can trigger by going into a certain folder or viewing a certain file.

If you have Acronis TrueImage installed, start by disabling its shell extensions as they've had really bad memory leaks in the past.


#14

Thanks. Yes while MrC told me VMMap isn't that good it was all I knew so was trying to make it work but your suggestion is what I was looking for. So I've done as you suggested and we'll see if it does it again. I disabled a bunch that I think were unnecessary. If it does it again I'll start disabling some others and see.


Opus using 7GB of RAM part 3
#15

Ok I disabled every extension I could see that wasn't DOpus or Microsoft but I'm still experiencing the high memory usage. Attaching the saved list in case anyone can look at it and see something that seems strange.
extensions.txt (255 KB)


#16

(Rebooting after disabling the shell extensions may be important, if you didn't do that already.)

Another thing to try is disabling all viewer plugins in Opus.

Without a clue about which actions / folders / files might be triggering the problem, it's hard to know what best to suggest, but there's a list of other ideas here: General slowdown or instability investigation steps


#17

I'd rebooted after each disable. I just disabled all viewer plugins as you suggested but it's still doing it. These last few times it's done it I did nothing but open it and leave it running while I browsed and so forth.


#18

Does it do that even if you open it to a completely empty directory and leave things there?

For the best test, create an empty folder on your desktop, quit Opus and make sure dopus.exe isn't running, then right-click the empty folder and choose Open in Directory Opus to load Opus showing that folder, without any other folders being loaded. (If your default lister has other tabs which open on startup, get rid of them, re-save the default lister, then exist dopus.exe and open the folder. That way the other folders/tabs are ruled them out, and only that empty folder is ever loaded.)

Another thing to try: Set Preferences / Miscellaneous / Advanced: no_external_change_notify to TRUE and see if it still happens. (You'll want to set it back to FALSE after doing the test, though, since it will stop Opus noticing changes to folders.)


#19

Well so far after changing the no_external_change_notify to true it has not done it yet. I'd tried this once before (before disabling all shell extensions and plugins) and noticed just what you mentioned and so turned it back to false but I'm leaving it now and I've used DOpus, Gone to directories, viewed movies, etc. So far it has not shown that memory usage increase.


#20

Btw thanks for your time on this.


#21

No luck. It just did it again. Even with that set to true and all extensions other that Microsoft and DOpus ones disabled via ShellExView and all viewer plugins disabled. I don't have any other folders opening with the default lister and when i right click on my empty folder I do not have the option to open in Directory Opus. Right now I just opened it and I'll leave it alone completely and see if it happens. I think I did this before and it did but I'll double check.


#22

Annnnnd the answer to your question is yes. All I did was open DOpus and left it minimized. Woke this morning and it was using 14 gigs of memory.


#23

You should be right-clicking the empty folder on the desktop, not in Opus.

(If Opus is already running then the experiment has failed, as the point is to launch Opus so that the only thing it has ever viewed is an empty folder. That way we rule out the possibility of something in another folder being the trigger for the problem. Before right-clicking the folder, ensure Opus has been fully exited and dopus.exe is no longer in the Task Manager process list.)

If you're doing that but the option isn't there, you might need to turn on Preferences / Miscellaneous / Windows Integration / Add 'Open in Directory Opus' item to folder context menus.

(If you have Explorer Replacement enabled then the menu item is always added -- it has to be for Explorer Replacement to work -- and that option will be disabled.)


#24

Ah that option was turned off. I'll turn it on and do that and let ya know. Thanks again!


#25

Ok so far it hasn't spiked when I open that folder and just leave it.