Missing Extension Default Action

I'm trying to figure out a way to use the Directory Opus "File Types" menu to configure a specific application to open when I am opening a file without an extension.

For instance, when I open a file with no extension right now, I am prompted (by Windows 7 I'm guessing?) for which application I would like to open it with. I understand the reasoning behind this, however, I find that I open almost all files without an extension with Notepad++. I am trying to find a way, through DOpus, to open all files without an extension with Notepad++ automatically without going through the "Open With..." dialog.

Does anyone have any experience with this?

In the settings -> file types menu there is an entry "unknown file type" with no extension. If you choose "edit", you can define things in the event tab, like the Left Double Click, which you can set to your Notepad++ path:

"c:...\notepad++" "%1"

Hmm... That is what I originally tried, and tried again just now. It doesn't seem to change the behavior. Just to be sure I understand you, you are talking about the "Unknown file types" item under the "Directory Opus File Types" section?

When I make this change and edit the "Left double-click" item to point to Notepad++ and then save my changes and come back to a file without an extension I still get the "Open With..." dialog when I double-click.

So far I've only been able to see a change when I apply it to the "All files" item. However, when I do that, then every file I double-click opens in Notepad++ regardless of extension or no extension.

Not sure. You could try testing the same with Shift or Alt click, to see if it works then. Maybe the simple click is occupied.

If it's just text-files you care about, and they really are text files (no binary data), then just turn on Settings -> Preferences -> File Operations -> Double-click on Files -> Open unregistered file types in text viewer if they appear to be plain text.

Yep, that worked! Thanks Leo!

I'm not sure why the other approach didn't work for me, because it seems like it should have. Thanks for your help!