<missing string> in Plugin Configure dialogs

I am using Directory Opus (the latest version downloaded from your website) with an evaluation certificate. My OS is Windows Vista Enterprise SP1, with all Windows updates up-to-date.

The problem I am having in Directory Opus is that some of the plugins' Configure dialogs seem to be corrupted and all the places in the dialogs that have text (buttons, descriptions, options, etc) say instead.

I tried doing a COMPLETE uninstall of Directory Opus (with reboot) and then installing it again (with reboot), but the problems persist, even before I loaded my saved DirOpus settings into the new install. :cry:

The following plugins' Configure dialogs exhibit this problematic behavior:
[ul]* Animated GIF

  • ActiveX + Preview + Office + Web
  • Text File Thumbnails[/ul]
    The following plugins' Configure dialogs appear normally:
    [ul]* TGA, JPEG 2000, PNM, Rasterfile, and Raw Digital Camera
  • Movie
  • MP3 Format Sound File
  • Text[/ul]
    All plugins were included in the Directory Opus installation, I did not alter them in any way nor did I install them separately.

Just to make sure that these problems are not related to viruses/spyware/etc, I have scanned my entire HD for viruses with McAfee AntiVirus (with up-to-date definitions) and for malware/spyware/etc with AdAware 2008 (also with up-to-date definitions); nothing was found, and I have not experienced any other issues with Windows itself (that I am aware of).

I also did a command-line scan "sfc /scannow" to make sure that my system files are okay, and that did not find any problems either.

I do NOT have UAC turned on for now, so my problem cannot be from UAC.

Please let me know if you need further information. I apologize if this has already been addressed; I searched the forums for information about this problem, but did not find anything. Thank you in advance for your help.[/img]

Which language do you have Opus in?

Does the problem go away if you set it to English?

The messages mean that the translation Opus is using does not have the plugin's strings in it. As far as I know all language packs that come with should have all the required strings.

The language DLLs are stored here, if you want to take a look at the dates and version numbers to check whether anything looks wrong:

C:\Program Files\GPSoftware\Directory Opus\Language

Have you rebooted since installing?

Most software tries hard to play nice with Windows, but there are too many times when it pays to reboot. You never know which bits of stuff on your PC might be hanging on to files that other things need to get at.

The language I am using is already English.

In the directory C:\Program Files\GPSoftware\Directory Opus\Language, the following is shown in the Details tab of the english.dll Properties dialog:

  • File Description: Directory Opus 9 English Language Pack
  • Type: Application Extension
  • File Version:
  • Product Name: Directory Opus
  • Product Version: 9, 1, 0, 6
  • Copyright: Copyright (c) 2008 GP Software
  • Size: 496 KB
  • Date Modified: 5/2/2008, 4:17 PM
  • Language: English (Australia)
    Also, the Advanced Attributes dialog has "File is ready for archiving" checked (not sure if that makes any difference.)

Does any of this seem incorrect, and if so, what can I do?

Yes, I did reboot since installing. I also tried (1) completely uninstalling Directory Opus, then (2) rebooting, then (3) installing Directory Opus again, and finally (4) rebooting again. No change. :frowning:[/b]

That all looks fine to me.

Do you have

C:\Program Files\GPSoftware\Directory Opus[b]dopus.exe[/b]


C:\Program Files\GPSoftware\Directory Opus[b]Viewers\docs.dll[/b]

as well? If the parts in bold are not the same then that would cause problems. (e.g. If dopus.exe has been renamed to something else then the plugin won't find its strings.)

I just wanted to add, the issue seems to persist EVEN IF I CHANGE THE LANGUAGE, so it does not appear to be specific to the english.dll language file.

I tried changing the language (in Preferences) to Spanish and restarting DO. Everything that had shown correctly in English was ALSO shown correctly in Spanish, but all the places that had when language was English STILL said when language was Spanish, even after restarting DO.

The same happened when I tried changing it to French and restarting DO.

What could cause this problem to occur regardless of the language that is set? I downloaded the digitally signed version of DO straight from the website, so all the language DLLs came from that installation. Since I have confirmed that the problem is occurring even when different languages are set, I think that something else must be causing the issue, because it would be very odd for ALL the language files to be corrupted (even though I've never used any of them, besides English, until today).

Could there be any other reason? Or could it be a problem with some registry keys?

Also, both dopus.exe and docs.dll are in the locations that you specified.

Nevermind, I figured it out. :slight_smile:

For some reason I had a back up of an older version of dopus.exe (renamed to dopus.exe.bak) in the Directory Opus folder, but after I deleted that, the strings show up correctly now. I'm not sure why it made a difference, since I DID have the up-to-date dopus.exe in that folder TOO, but I'm just glad it is fixed now. :slight_smile:

Thank you for your help though - I would not have found it if you did not mention that the dopus.exe file itself could be relevant to this particular issue.

That's what you get for running illegal patches :wink:

Actually, my 60-day evaluation (for which I officially registered) is still active until August 3 - no illegal patches or anything of the sort. :slight_smile:

I realized that I had left the older version of DO on my HD, just because sometimes I prefer older versions of software. Many program updates (fortunately not DO, as it turns out - but this is just my general experience overall) keep adding on more features, so the program gets larger and uses up more resources. Also, sometimes some functionality is removed or made more difficult to utilize in order to "protect users" and such.

Anyway, the latest update of DO is great - no problems - so I certainly will not be needing the old backup files anymore. :slight_smile:

In any case, the (false) accusation is a bit upsetting. :cry: I am well aware that illegal patches only bring trouble; I have not used them and never will.

So, in order to prevent a new version screwing your system you screwed your system. Brilliant! :smiley:

It's best to backup the installers for old versions, rather than the exe files themselves.

Actually, I did not screw my system. Usually .bak files do not interfere with anything - and in this case they seemed to be a problem for DO, not for my entire system, and even that was fixed by just deleting them.

That is a good point and you are right. I have no idea why I did not do that, because in most cases I do.
**Note to self: don't try to configure new installations and/or backups on 2 hours of sleep... :unamused: